Plain text on markdown is not displayed if I select a long time range

Hello,
I am on kibana 7.10.2 and when I create a TSVB Markdown visual with only plain text (or with an image), and then I select a time range of one year, the visual loads a long time until this error :

Thanks

Hey! I can't replicate it. If you use a markdown viz instead does it also happen? You can use this instead if you just want to display a plain text.

image

Thanks,
Indeed with Markdown it works.
But I used custom css that can't be set in Markdown

Ok I see. The problem is that TSVB is used for timeseries indexes. TSVB markdown has been created to render dynamic data based on aggregations. For this reason it is related to the timepicker.
Just for curiosity, how have you set your panel options? Which index pattern do you use?

Oh I see
I'm using the default index patern heartbeat*

Ok so it seems that the timeout occurs due to this index pattern. I am not sure if we could hack it somehow, create a very simple timeseries index with a few of documents and use this instead. But again, it is not the correct way. I think that the team that is responsible for the markdown viz wants to add styling support in the future.

I see, thanks !

1 Like