POST URL Report Generation 404 Not Found

I have gone through all related topics and cannot seem to find a solution to my problem.
If I generate a csv report from Kibana web UI, I am able to download it from Stack Management > Reporting > Download report. The size of my report does not exceed 5MB.

Now, if I use POST URL to try to trigger the report outside of Kibana, I get the JSON response with the GET request to download the report but when I open it in the browser, I get the following:

{"statusCode":404,"error":"Not Found","message":"Not Found"}

I am using the kbn-xsrf header - I have tried kbn-xsrf: true and kbn-xsrf: reporting, both yield the same result.

Postman screenshot:

The status in the JSON response to the POST request is Pending and attempts:0, could that be related to the problem?

I used the DevTools to search for pending reports and there were 0 hits. It also does not take long when I use the UI. Please advise.


What is the version of your elastic stack please? and could you please post the post URL command fully here? (please blur any sensitive information)


Hello, we can close this topic now. It seems the issue was that I also needed to add the basic auth and kibana header to my GET requests.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.