Problems configuring Kibana 3 +NGINX

Hello, I'm very noob in all of this.
I have been seeing some tutorials online but it doesn't work for me.

I want to configure a Logstash+Elasticsearch+Kibana
In order to see the logings from any browser typing "http://IP:80"

In my kibana config.js I have this>

 * ==== elasticsearch
     * The URL to your elasticsearch server. You almost certainly don't
     * want +http://localhost:9200+ here. Even if Kibana and Elasticsearch are on
     * the same host. By default this will attempt to reach ES at the same host you have
     * kibana installed on. You probably want to set it to the FQDN of your
     * elasticsearch host
     * Note: this can also be an object if you want to pass options to the http client. For example:
     *  +elasticsearch: {server: "http://localhost:9200", withCredentials: true}+
    elasticsearch: "http://localhost:80",

In my nginx.conf I have

# Nginx proxy for Elasticsearch + Kibana
# In this setup, we are password protecting the saving of dashboards. You may
# wish to extend the password protection to all paths.
# Even though these paths are being called as the result of an ajax request, the
# browser will prompt for a username/password on the first request
# If you use this, you'll want to point config.js at http://FQDN:80/ instead of
# http://FQDN:9200
server {
  listen                *:80 ;

  server_name           localhost;
  access_log            /var/log/nginx/;

  location / {
    root  /var/www/kibana3;
    index  index.html  index.htm;

  location ~ ^/_aliases$ {
    proxy_read_timeout 90;

When I try to access to IP:2900 I obtain the elasticsearch configuration >

  "ok" : true,
  "status" : 200,
  "name" : "Franz Kafka",
  "version" : { .... 

So it seems to be OK.
However when I try to access to IP:80 I obtain the NGINX welcome page instead of the KIBANA page...
Could you please tel me where could be the problem? I'm sure that it isbecause the configuration files..

Please help me
Thank you very much

Is your Elasticsearch cluster really running on port 80? By default, it runs on port 9200.

Thanks for your response Tanya. I have changed it. But when I change it and I write on my browser http://'ip':80 I obtain the same Welcome page of NGINX.

I have a very simple local setup that works.

Here is my nginx config (i'm not configuring aliases):

server {
    listen       8080;
    server_name  localhost;

    location / {
        root   /path/to/kibana-3.1.2;
        index  index.html index.htm;

And kibana-3.1.2/config.js:

  return new Settings({
       elasticsearch: "http://localhost:9200",

So, you're on the right track, probably some minor configuration detail is missing.

Hi Tanya,
Thanks for your help.
I have this in my configuration files.

I have been able to conect with the graphical interface of Kibana. However I can't see the elasticsearch config by http://IP:9200... while from my server I'm able to do it with http://localhost:9200

Besides I have 2 errors in Kibana.

" Upgrade Required Your version of Elasticsearch is too old. Kibana requires Elasticsearch 0.90.9 or above."

"Error Could not reach http://localhost:80/_nodes. If you are using a proxy, ensure it is configured correctly"

And I'm using Elasticsearch 0.90.9

What do you think about it?

From the error message, it appears that Kibana is still looking for Elasticsearch on port 80 instead of 9200. Could you double-check your config again?

that was it! Thank you very much Tanya :smile: