Problems to create an index pattern

Problems to create an index pattern

I have a problem when I'm trying to create an index pattern in Kibana.

I have a system configured in the Elasticsearch cloud for my company, and I access it with a user with superuser role.

The problem is that when I go to the corresponding section to create an index pattern, I follow the steps indicated by the system and it seems to be created, but then it always tells me that I have to create one.

I pass screenshots of the process, so you can see what happens.

Step 1: I write kibana * to select two indexes that already exist. They were created by loading sample data from the platform.

Step 2: In the next step, I select the field @timestamp and I give it to Create index pattern.

Step 3: It seems that the index pattern has been created, because it already gives me the name, and the star as it is the default index pattern

But when I go to Discover section, I'm asked again to create an index pattern.

Could you help me? I have tried several types of data, with two different users and also with 3 browsers (Chrome, IE and Firefox) without success.

Many thanks

Does this mean that you aren't seeing index patterns for kibana_sample_data_ecommerce or kibana_sample_data_logs in Discover either? Because if those index patterns are present, you should be seeing data from them in Discover.

I assume the sample data were added using the Kibana UI? (/app/kibana#/home/tutorial_directory/sampleData). If sample data isn't showing up in Discover either, you could try removing and re-adding it to see if that helps.

Indeed, I do not see the sample data loaded in Discover either.

Yes, I load the data through the Kibana UI, but when I try to create an index pattern for the loaded test data, it does not load either.

These are the tests I have done so far:

  • I have loaded test data with two users with superuser role. In both cases, the data is loaded, but when I access the menu to create the index pattern, the system behaves as indicated in the first message. It does not show any error message when creating the index pattern, but it is not created afterwards.

  • I have done the same tests with 3 different browsers to verify that it was not a problem of compatibility with browsers or a problem of system cache. I have tested with IE, Chrome and Firefox.

  • I have reviewed the configuration of the index .kibana, in case it was configured as read-only, but I have not found any problem in the configuration (this is the configuration of the .kibana index)

  • I have checked that the system has enough space. It is a new cluster (we have registered it on May 1st). I enclose a screenshot with the current status of the cluster.

  • I have also checked if an index pattern created using the query appeared in the saved objects.

    GET /.kibana/_search
    "query": {"match_all": {}}

I attach the result here

  • Finally, I tried to load a data directly from a CSV file, to create the index pattern automatically during loading, but the system loads the data without creating the index pattern, although I expressly set the option that You must create it. During the loading process, the system indicates that it have created it, but it does not appear afterwards.

Thank you,

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.