Problems with Apache reverse proxy and elasticsearch bigdesk plugin

I've problems with elasticsearch plugin in general, bigdesk, head, HQ etc...

i need not port open 9200 port to the outside.

I put my apache configuration for the kibana side:

ProxyRequests On
ProxyPreserveHost On

/# Redireccion para kibana
ProxyPass "/logs" http://serverhostname:5601
ProxyPassReverse "/logs" http://serverhostname:5601

/# Redireccion para elasticsearch

ProxyPass "/els" http://serverhostname:9200
ProxyPassReverse "/els" http://serverhostname:9200

/# Redireccion para Bigdesk

ProxyPass "/bigdesk" http://serverhostname:9200/_plugin/bigdesk (my problems is here)
ProxyPassReverse "/bigdesk" http://serverhostname:9200/_plugin/bigdesk (my problems is here)

/# Proxy options

Order Allow,Deny
Allow from all
AuthType Basic
AuthName "LogServer"
AuthUserFile /example/htpasswd.controlusers
Require valid-user

Order Allow,Deny
Allow from all
AuthType Basic
AuthName "ELS Server"
AuthUserFile /example/htpasswd.controlusers
Require valid-user
*I sustituded some parameters for the security og my company, don't worry.

When i try to open http://myserver/bigdesk only works if i put the port :9200 but is just to need exclude, the other locations /els and /logs works correctly.

Attach the screenshot,i clean the personal data. The proxy permit pass through but don't put the port and to this way don't work.

Please i appreciated any help, thx so much.



I have the EXACT same problem. :frowning: