PUT mappings API overriding the exsisting mappings


I have created an index template, where I am defining an "ignore_above" mapping parameter for a "keyword" field type.

Now I want to update the mappings and want to add a new parameter "eager_global_ordinals" for the same "keyword" field using the PUT mappings API,

I can see the API returning 200OK.

So to verify the mapping when I call GET index-name, I can see the new mappings "eager_global_ordinals", but not able to see "ignore_above"?

I checked, and found out that "ignore_above" property is getting overrided with default value?

Meaning PUT mappings API overriding the mappings parameter to default value, if i dont pass any.

is there any way to avoid this behavior?

Any help is much appreciated!! Thank You!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.