Removing failed ECE deployments in Cloud UI

ECE 2.2
Issue: I have two deployments showing in the Cloud UI that are stuck in the "Deployment Not Found" stage and I'm trying to clarify how to clear them out correctly.

From what I understand of the post linked below I should log in to one of my Coordinator nodes and run two commands since I dont have access to the API console.

1 `curl -XPOST -u 'admin:PASS' 'localhost:12400/api/v1/clusters/elasticsearch/ID/_shutdown?skip_snapshot=true'`
2 `curl -XDELETE -u 'admin:PASS' 'localhost:12400/api/v1/clusters/elasticsearch/ID`

The API reference table has some minor syntax changes but this seems like the general route that I need to take to remove them from the Cloud UI.

Yes - that sound right. Sorry about that!


Alex, appreciate the quick response. With ECE are there any other steps that you need to take in order for these commands to work with a TLS enabled environment. Generally in our environment if I add -k or --insecure to the end of a command it goes through. As of right now I'm not getting that to work.

sudo curl -XPOST -u admin:<password from installation> "<cluster id>/_shutdown?skip_snapshot=true" -k
  "errors": [{
    "code": "root.unauthorized.rbac",
    "message": "The supplied authentication is not authorized to access this resource. Reason: [Not Found]."

Reason: [Not Found] implies the cluster id is wrong

If you curl api/v1/clusters/elasticsearch does the cluster id you have been using get returned?

If not, same question for api/v1/clusters/elasticsearch/_search?q=*

If it appears in the _search but not the GET then that is a known sync bug with an easy workaround (DELETE v1-elasticsearch-clusters-ece-region/elasticsearch-cluster/:id from the Adminconsole cluster, eg using that cluster's API console)

Ok so I was able to get this all worked out which is appreciated! My Linux skills aren't very good so theres probably an easier way to do this but I got info with

curl -X POST -u admin:<password> "*" -k

Updated that with -o to send it to a file since I couldn't read all of the output

curl -X POST -u admin:<password> "*" -k -o cluster_post.txt

Ran the same thing with the GET

curl -X GET -u admin:<password> "https://xx.xx.xx.xx.xx:12443/api/v1/clusters/elasticsearh" -k -o cluster_get.txt

Checked the files, as you mentioned the cluster_id's appeared in the search but not the GET output

grep <cluster_id> cluster_post.txt
grep <cluster_id> cluster_get.txt

Cloud UI --> admin-console-elasticsearch --> Elasticsearch -> API Console --> DELETE v1-elasticsearch-clusters-ece-region/elasticsearch-cluster/<cluster_id>

Worked perfectly. Thanks again for the quick help @Alex_Piggott!!!

1 Like

This topic was automatically closed 14 days after the last reply. New replies are no longer allowed.