Reporting generate CSV error:Unable to generate report Max attempts reached (3)

When I generate a report in kibana, the maximum CSV file I can successfully generate and download is 986062 bytes, which contains 6586 hits, and cannot be successfully generated when there are more than 10000 hits. And I have config some related fields in kibana.yml, but it still can't generate CSV.
kibana.yml :
xpack.monitoring.enabled: true
server.maxPayloadBytes: 10485760
xpack.reporting.queue.timeout: 3600000
xpack.reporting.csv.maxSizeBytes: 104857600

AND I can't find the error detail in kibana.log:confounded:


@joelgriffith can we please get some help here?


I'd like to know why I can't generate a CSV file larger than 1KB, and why I can't find the reporting error information in the kibana.log.
Thank you for your help.

@_Jiawen can you set your logging to:

logging.verbose: true

This should give us some better logs on what's going on inside of reporting.

Thank you for your replay.
Do you mean this :
logging.verbose: true
logging.quiet: false
I add this into kibana.yml and encountered an error that prevented kibana from starting, and I haven't been able to fix it yet. My kibana startup is started through a script that I wrote myself.
the following error:
ValidationError: child "logging" fails because [child "verbose" fails because ["verbose" must be one of [false]]]

Apologies for that, could you try this setting instead (removing that other config I sent)? ['warning', 'error', 'fatal', 'info']

Do you mean try this setting in kibana.yml? I didn't find any details about this setting.

I tried add this setting in kibana.yml, but kibana.log hasn't changed, and when the report failed still doesn't display details in kibana.log

I think I found the problem.
I found an error message in the access.log of Nginx: "POST /.reporting-2019.05.05/esqueue/jvhqzbtn0ixp3d278gyb3/_update?version=2 HTTP/1.1" 413 199 "-" "-" "-" "0.043" "-" - -.
The server returns a status code of 413 means that the uploaded file is too large, the related parameter is client_max_body_size which defalut is 1M , modify the client_max_body_size in nginx.conf can solve my problem. Although I still can't find any detail in kibana.log.
Thank you for your help.:smiling_face_with_three_hearts::smiling_face_with_three_hearts::smiling_face_with_three_hearts:

Glad you found it! There is some logging we do when there's a discrepancy between elasticsearch and kibana, but it's not foolproof.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.