Request _cat/shards display index_closed_exception

Hi, My Cluster version is 6.4.2 , I closed part of the index for storage reasons。
When I request this api, Response request is index_closed_exception 。

Hi @test987654123,

This is correct behaviour. Also, can you be more clear about your query?

Nikhil Kapoor

This is correct behaviour.

I don't think this is a correct behavior. When you close an index, it should not interfer with other APIs IMO.

My Cluster version is 6.4.2

Could you try with the latest 6.5 version?

Upgrade the cluster, I need to migrate hot data,
But I found that I can't get it Index

Sorry I don't understand what you wrote.
What do you mean?

Sorry, I am preparing to migrate the cluster. Because of the hot and cold data separation strategy, some indexes cannot be retrieved directly.

May be just open the closed indices?

Hi @dadoonet,

Yes, you are right. This is not a correct behaviour.

"index_closed_exception" should have been shown, if the index is closed and user have executed the below command:

curl -X GET "10.x.x.x:9200/_cat/shards/index_name"

Where, index_name is the name of the closed index

Nikhil Kapoor

Hi, The cluster has been upgraded to the latest version, and the problem is still not solved.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.