INDEX IN CLOSED STATE NOT ABLE TO OPEN

hi all ,
we did rollback to our server after that suddenly all indices went to closed state

What do you mean by "rollback"?

What do the logs on the master node show?

Elasticsearch does not support downgrades to an earlier version. If indices has been accessed in a newer version they can no longer be opened by nodes running an older version.

It is not clear to me exactly what you have done. Could you please elaborate? It would also help if you shared a lot more of the logs...

indexes went to closed state , not able to open indexes after that . showing error

i have checked this one also but still couldnt find anything : Failed to process cluster event Exception

What did you do to Elasticsearch and the host on which it is running that resulted in closed indices?

Also please provide more of the logs. The excerpt you provided lacks context.

i tried restarting it still not working , can some help me here

Please check /var/log/elasticsearch.

It'd be good if you could share a bunch of the log, it provides context to what is happening and we may be able to identify something you have missed.