Running elasticsearch 5.0.0 on a raspberry PI 3


(glagidse) #1

How can I run elasticsearch on a Raspberry Pi 3 over a network? If I try to run it on a localhost it works, but if I try to run it over a network I get the following error:

[2016-10-27T23:09:39,941][INFO ][o.e.t.TransportService ] [node-1] publish_address {192.168.0.151:9300}, bound_addresses {192.168.0.151:9300}
[2016-10-27T23:09:39,964][INFO ][o.e.b.BootstrapCheck ] [node-1] bound or publishing to a non-loopback or non-link-local address, enforcing bootstrap checks
ERROR: bootstrap checks failed
max virtual memory areas vm.max_map_count [65530] likely too low, increase to at least [262144]
[2016-10-27T23:09:40,000][INFO ][o.e.n.Node ] [node-1] stopping ...
[2016-10-27T23:09:40,082][INFO ][o.e.n.Node ] [node-1] stopped
[2016-10-27T23:09:40,084][INFO ][o.e.n.Node ] [node-1] closing ...
[2016-10-27T23:09:40,177][INFO ][o.e.n.Node ] [node-1] closed

I understand that by reading the documentation that by setting network.hosts to a non local address sets elasticsearch up in production mode and adds a bunch of extra checks, but I don't want any of that. How can I run elasticsearch over a network without production mode? Raspberry pi doesn't have enough memory to run in production mode.


(David Pilato) #2

You can't. If host is set It means you need to fix all production potential issues.


(Mark Walkom) #3

What do you mean? Just set the heap lower.


(glagidse) #4

Doesn't work I've set -Xms512m -Xmx512m but that apparently isn't enough apparently, Raspberry pi 3 only has 1 gb ram. I figure I can get around it by creating a virtual network card and bridging it to my loopback address, because it works if I run it locally. But I've just gone back to an earlier version where it does work so it's all good.


(Mark Walkom) #5

Apparently, why?


(glagidse) #7

Because the log says so:
max virtual memory areas vm.max_map_count [65530] likely too low, increase to at least [262144]


(Mark Walkom) #8

That's not heap, see https://www.elastic.co/guide/en/elasticsearch/reference/5.0/_maximum_map_count_check.html


(Chris K) #9

Disabling the bootstrap check in the elasticsearch yml file should fix your problem


(Luca Belluccini) #10

You can increase it in sysctl vm.max_map_count


(system) #11