Running FSCrawler in Debian 10, results in `command not found`

I'm trying to run fscrawler on Debian 10. I have downloded both fscrawler-es7-2.8-SNAPSHOT.zip and fscrawler-es7-2.7.zip then exctract them to /home/myname/fscrawler, but running these codes always results in command not found !!
First I ran these :slight_smile:

export JAVA_HOME=/usr/lib/jvm/java-11-openjdk-amd64

and then I tried:

myname@debian:~/fscrawler$
sudo bin/fscrawler job_name
sudo ./bin/fscrawler job_name
sudo /bin/fscrawler job_name

sudo /bin/fscrawler --config_dir /home/ehsan/fscrawler data >> /home/ehsan/fscrawler/logs/fscrawler.log 2>&1


I created /logs/fscrawler.log. I do not know what to do to run this crawler?

What is the output of:

ls -l ~/fscrawler

Thanks for quick replying.

echo $JAVA_HOME
/usr/lib/jvm/java-11-openjdk-amd64


ls -l ~/fscrawler
total 52
                drwxr-xr-x 2 ehsan ehsan  4096 Nov 24 11:39 bin
                drwxr-xr-x 2 ehsan ehsan  4096 Nov 24 11:39 config
                drwxr-xr-x 2 ehsan ehsan 16384 Nov 24 11:40 lib
                -rw-r--r-- 1 ehsan ehsan 11358 Oct 24 23:47 LICENSE
                drwxr-xr-x 2 ehsan ehsan  4096 Nov 24 11:47 logs
                -rw-r--r-- 1 ehsan ehsan   137 Oct 24 23:47 NOTICE
                -rw-r--r-- 1 ehsan ehsan  5642 Oct 24 23:47 README.md

Sounds good.

Could you run:

cd ~/fscrawler/bin
ls -l
./fscrawler

Thanks for replying.

ehsan@debian:~/fscrawler/bin$       ls -l
      total 8
      -rw-r--r-- 1 ehsan ehsan 1620 Oct 24 23:47 fscrawler
      -rw-r--r-- 1 ehsan ehsan 1739 Oct 24 23:47 fscrawler.bat

ehsan@debian:~/fscrawler/bin$ sudo ./fscrawler
         sudo: ./fscrawler: command not found

The files are not executable.

chmod u+x fscrawler 
./fscrawler 

Should work

1 Like