Saved Objects, Visualized items and Dashboards is missing

Currently i develop dashboards and visualization in Kibana. In the next days, there are error when opening kibana with error message like this:
{"statusCode":500,"error":"Internal Server Error","message":"{illegal_argument_exception: [illegal_argument_exception] Reason: application privileges must refer to at least one resource]: application privileges must refer to at least one resource"}

Then after restarting kibana service, all the dashboards, visualizations and saved objects are missing.

  1. Why these error happened?
  2. Can i get back my dashboards, visualizations and saved objects into my Kibana?
  3. Where the dashboards, visualizations and saved objects located in storage?

Hi @Brisma and welcome to the community!
I need a bit more info to help debug the issue. Could you please let us know what version of the stack you're running, how you're running it (from source or a product download) and if you can access Elasticsearch?
To see if Elasticsearch is responding, what do you get from the curl: curl -XGET <es-endpoint>:9243 -u <username>:<password> where the username and password are your Kibana auth credentials.

Hello @cheiligers. Thanks for asking
Currently i use elastic 7.14 on my Linux VM.

I tried using curl -XGET :9243 -u : and the response was "curl: (7) Failed connect to; Connection refused"

But when i access curl using port 9200 and 5601, both of them respond the request as usual.

for now, i tried to find the Kibana saved objects in the VM storage. Where is the path or location?

Saved objects are stored in the .kibana index in Elasticsearch. You should find that data in the same location as your Elasticsearch data is stored. The installation guide for Linux machines gives the directory structure for .tar.gz files.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.