Security information not being output on startup (8.0.0-rc2)

Tried setting up Elasticsearch 8.0.0-rc2 on macOS to test the new security configuration. Despite what the documentation says, no password, enrollment token, etc. is being output on first startup. Instead, the following is output:

[INFO ][o.e.x.s.InitialNodeSecurityAutoConfiguration] [MacBook-Pro.local] Auto-configuration will not generate a password for the elastic built-in superuser, as we cannot determine if there is a terminal attached to the Elasticsearch process. You can use the bin/elasticsearch-reset-password tool to set the password for the elastic user.

Tried with both ZSH and Bash.

I was able to set things up just fine by using bin/elasticsearch-reset-password -u elastic and bin/elasticsearch-create-enrollment-token --scope kibana.

My question is just why nothing is being output by default as the documentation states? Any way to fix that? Thanks.

Hi there, thanks for your report ! I can’t reproduce this on macOS 11.2.3

Can you please share how you installed Elasticsearch and how you are attempting to start it , along with details about your macOS version ?

Sure. I am using macOS Monterey 12.1 on ARM (M1 Pro). Simply downloaded Elasticsearch for the macOS aarch64 platform from the download page. Extracted the archive and ran bin/elasticsearch and ./bin/elasticsearch (no difference). That's all. :slightly_smiling_face:

FYI, as mentioned in my first post, I am using ZSH, but also tried with plain Bash, and the result was the same. Just thought I'd mention it again since it might be relevant based on the info message.

Thanks again for reporting this @Andy0708 ! We have determined that this is a bug on our side affecting aarch64 and we're resolving it in

Awesome, thank you so much, @ikakavas!

1 Like

Sorry to open this again, @ikakavas, but this is still an issue on 8.0.0. I see that it is mentioned within the release notes. Do you have any idea when this will be fixed? I have various content that I am unable to update to support version 8.x until this is fixed. Thanks! :slightly_smiling_face:

Hi @Andy0708 , this is fixed and will be released in the next patch and minor versions , so 8.0.1 and 8.1.0. We unfortunately cannot commit to dates for future releases but these will be available soon !

Perfect, thanks again! :slightly_smiling_face: I just thought it made it into 8.0.0, that's why I asked. :wink:

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.