Security is enabled by default when debug

Hi, I compiled es 6.8.5 from source code with the command ./gradlew run --debug-jvm , and I want to debug with IDEA, but the is default true, it's so inconvenient for debug. I ever compiled 6.4, it's default false. The generated package is in distribution/build/cluster/run\ node0/elasticsearch-6.8.5-SNAPSHOT, and the generate config is below: distribution_run node-0
pidfile: /Volumes/Files/Study/Elastic/ES/source/elasticsearch/distribution/build/cluster/run node0/
path.repo: /Volumes/Files/Study/Elastic/ES/source/elasticsearch/distribution/build/cluster/shared/repo
path.shared_data: /Volumes/Files/Study/Elastic/ES/source/elasticsearch/distribution/build/cluster/shared/
node.attr.testattr: test
discovery.zen.master_election.wait_for_joins_timeout: 5s
node.max_local_storage_nodes: 1
http.port: 9200
transport.tcp.port: 9300
cluster.routing.allocation.disk.watermark.low: 1b
cluster.routing.allocation.disk.watermark.high: 1b
cluster.routing.allocation.disk.watermark.flood_stage: 1b
script.max_compilations_rate: 2048/1m
xpack.monitoring.enabled: true
xpack.sql.enabled: true
xpack.rollup.enabled: true true
discovery.zen.hosts_provider: file []

All these files are re-generated when I build. How can I disable the And I remember the security is disabled in basic license, but now it's enabled.

I have found the solution: comment setting '', 'true' in distribution/build.gradle.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.