Security when using Selenium RemoteWebdriver with Kibana

Morning all,
I am having some issues with how selenium is interacting with Kibana. For the body of work completed I was running on version 7.6.1 of Kibana with all of my automated tests passing on both the Selenium ChromeDriver and RemoteWebDriver. However, I then updated to version 7.9.3 of Kibana/Elastic, which has caused some unknown issues between Kibana and the RemoteWebDriver. Now, when I run the tests with ChromeDriver they pass as expected, but when I run them on RemoteWebDriver they fail.
The issue:
I tell Selenium to go the Kibana homepage to do some verification that Kibana is working for my project. However, when I tell it to go this homepage on the RemoteWebDriver it goes to some alternative page. I started to grab elements of this page under my test and I have gained the information that this is taking me to an unknown page which is saying:
‘Elastic failed to load. Check the server output for more information.’
Is there a known issue with this version of Kibana 7.9.3 interacting with Selenium RemoteWebDriver version 3.141.59?

Hi @NicklausKew!

Were you able to check the server output to see what the full error message is?

If you were able to get it working in 7.6.1, I couldn't find or think of a problem that it could be Kibana-side. Has anything else also changed in your environment?

If you're not able to get any of the error messages and you can't think of anything else changing in your environment, I'd probably start with going up 1 version at a time just to help isolate the issue but uncertain what it could be without more info.

Hi Michael,

I have checked the logs for this and I cannot see any error message in this, to indicate the issue at hand.

Also, when I changed back to version 7.6.1 the only thing I changed was the versions of Elastic Stack products. Thus, I have strong feeling it was something that has changed in the version of that.

Finally, I am working on an airgap system with no internet. This makes changing versions very difficult and time consuming. Do you not have any integration or nightly tests that run selenium on your products to test stuff like this out? My final question is, if I end up finding exactly what version of Kibana/Elastic that broke this, how will that help with the fix for the issue?

Hi @NicklausKew,

We use WebDriver for Kibana integration testing, we run them constantly for PRs/main branches and there were no any specific changes in test framework regarding session creation/ base url navigation, you may check the way we create session and what arguments we pass for each driver.

Hope it helps.

Regards, Dzmitry