Self monitoring won't enable 7.13

Trying to activate Self Monitoring in 7.13. The message logged to Kibana is

2021-06-15T14:16:46+00:00","tags":["warning","plugins","monitoring","monitoring","kibana-monitoring"],"pid":128991,"message":"Unable to bulk upload the stats payload to the local cluster"}

I see no .monitoring indexes being created.

I have tried setting

to the direct IP and 9200 of a cluster node.

Cleared true flag and retried with no difference.

At startup I am seeing this message kibana is 7.13 and Elastic nodes are 7.13

Waiting until all Elasticsearch nodes are compatible with Kibana before starting saved objects migrations

Installed a two node 7.9.2 cluster with 3 master nodes. Got the self monitoring working then upgraded to 7.13. This work around worked.

Self Monitoring being removed in V8.0
You see the warnings about this when running self monitoring on 7.13 and the recommendation to move to Metricbeat.

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.