Sending to data to Elasticsearch using logstash?

ES 2.4.1
Logstash 2.4.0

I am sending data to elasticsearch from local to create a index "pica".I used the below conf file.

input {
      file {
        path => "C:\Output\Receive.txt"
        start_position => "beginning"
        codec => json_lines
    output {
      elasticsearch {
        hosts => "http://localhost:9200/"
        index => "pica"
    codec => rubydebug

I couldn't see any output in either logstash prompt or in elasticsearch cluster.
When i seen the .sincedb file it has the following code:
612384816-350504-4325376 0 0 3804

May i know what's the problem here?


How big is Receive.txt? Is it a static file or is someone/something appending data to it?

It is a text file of size 4kb . It is not a static file. it is just a text file

Logstash is waiting for more data. Shut down Logstash, delete the sincedb file, then fire it up again.

Side note: I didn't ask for an approximation of the file size. I wanted to know exactly how big the file was, in bytes. That stuff matters.

Thanks for fast response..
I tried more than 5 times , every time deleting sincedb file but the problem remains..

size : 3,804 bytes
size on disk: 4,096 bytes

Can we please say whether my conf file code is good? Or need any other correction in that?


You can increase the logging verbosity and examine the resulting logs to better see what's going on.

Thanks ..
But i worked fine when i removed codec => json_lines in input configuration..

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.