Setting number_of_replicas on existing template

Apologize for the screenshot but my elasticsearch instance is in a secure environment with only a jumphost browser that cannot copy anything out.

Elastic Stack version 7.17.4 single node

I am trying to update an index template to create new indexes with number_of_replicas = 0. I tried to update through the API and it accepts it but afterwards the setting does not take and I don't see the number_of_replicas set at all. Here is the screenshot with the field that I added highlighted in yellow:


When I do a GET on the template after the PUT, the field is not there.

Can anyone tell me what I have to do differently?


Check the response of the PUT request. If the template was updated successfully, the response should be {"acknowledged":true}.


or go to kibana, stack management, index template and find your template.
then update it.

if it is still not keeping this value then one of the filebead daemon from a system is resetting it back.

you will have to check filebeat.yml file. and check " Elasticsearch template setting" section

Thank you for the response. I was getting back the acknowledged true. My mistake the new parameter was all the way at the bottom of template.settings.index array and not where I placed it in the request so I didn't notice it.

This is resolved. User error.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.