Setting up admin user credentials for Kibana

I am trying to impose basic security on my Elasticstack specifically user authentication for Kibana. I enabled xpack security by adding the following configurations in elasticsearch.yml file: true

Now my Kibana is stuck in state 'Kibana server is not ready yet' and Elasticsearch is asking for credentials which I have not set anywhere.

Also, the documentation says:

When you enable Elasticsearch security features, basic authentication is enabled by default. To communicate with the cluster, you must specify a username and password.

My question is, where can I specify this username and password?

Hi @usman1 ,

I believe the next steps for you are explained here:


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.