Setting up Cross Cluster Search in YML Causes Errors

I'm trying to setup cross cluster search via the example given in the documentation- however when I try to spin up elasticsearch it spits out a error

java.lang.IllegalArgumentException: unknown setting [search.remote.cluster_one.seeds] please check that any required plugins are installed, or check the breaking changes documentation for removed settings

I'm using Ansible to pass the search.remote parameters. I've tried various ways to specify the remote hosts in the yml, but none have worked. Any insight would be appreciated.

Here's whats in the Ansible file "EScluster",
search: {
remote: {
cluster_one: {
seeds: "centos009"

Which version of Elasticsearch are you using? What does the generated elasticsearch.yml file look like?

I've resolved the issue. I saw the 'major_version: 5.x' parameter in the elasticsearch ansible role and assumed it was pulling the latest stable version- however the default config has it hardcoded to 5.2.2.

Bumping to 5.4.2 did the trick.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.