Cross cluster search giving 504


(Matti De Grauwe) #1

Hi,

I would like kibana to cross search between 2 nodes:

1 being on the IP x.x.x.214
other one being on the IP x.x.x.215.

I've set up my configuration and the clustersetings return the following:

GET /_cluster/settings?pretty
{
  "persistent": {
    "search": {
      "remote": {
        "slave": {
          "seeds": [
            "x.x.x.215:9200"
          ]
        },
        "master": {
          "seeds": [
            "x.x.x.214:9200"
          ]
        }
      }
    }
  },
  "transient": {}
}

However, when I try to get my remote seeds I get the following:

GET /_remote/info?pretty
{
  "slave": {
    "seeds": [],
    "http_addresses": [],
    "connected": false,
    "num_nodes_connected": 0,
    "max_connections_per_cluster": 3,
    "initial_connect_timeout": "30s",
    "skip_unavailable": false
  },
  "master": {
    "seeds": [],
    "http_addresses": [],
    "connected": false,
    "num_nodes_connected": 0,
    "max_connections_per_cluster": 3,
    "initial_connect_timeout": "30s",
    "skip_unavailable": false
  }
}

What am I doing wrong?

Kind regards


(Christian Dahlqvist) #2

Cross-cluster search uses the internal transport protocol, so you should specify port 9300, not 9200 (which is the HTTP port).


(Matti De Grauwe) #3

Hi Christian, thank you for your quick response.

I did correct this on the master node by using the following API:

PUT _cluster/settings
{
  "persistent": {
    "search": {
      "remote": {
        "master": {
          "seeds": [
            "x.x.x.114:9300"
          ]
        },
        "slave": {
          "seeds": [
            "x.x.x.115:9300"
          ]
        }}
    }
  }
}

I'm still not receiving the expected results however.

GET _remote/info
{
  "slave": {
    "seeds": [],
    "http_addresses": [],
    "connected": false,
    "num_nodes_connected": 0,
    "max_connections_per_cluster": 3,
    "initial_connect_timeout": "30s",
    "skip_unavailable": false
  },
  "master": {
    "seeds": [],
    "http_addresses": [],
    "connected": false,
    "num_nodes_connected": 0,
    "max_connections_per_cluster": 3,
    "initial_connect_timeout": "30s",
    "skip_unavailable": false
  }
}

Kind regards,
Matti


(Matti De Grauwe) #4

Seems like the following command did the trick:

PUT _cluster/settings
{
 "persistent": {
   "search.remote.slave.seeds": [ "x.x.x.215:9300" ]
 }
}

(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.