Setting "xpack.management.enabled" hasn't been registered


#1

I am going to answer my own question, but this took me quite a long time to figure out, and the other person who asked this was never answered, so... I upgraded to 6.2.4 and started getting this error as soon as I start logstash.

[2018-05-14T16:58:28,775][FATAL][logstash.runner          ] An unexpected error occurred! {:error=>#<ArgumentError: Setting "xpack.management.enabled" hasn't been registered>, :backtrace=>["/usr/share/logstash/logstash-core/lib/logstash/settings.rb:37:in `get_setting'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:70:in `set_value'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:89:in `block in merge'", "org/jruby/RubyHash.java:1343:in `each'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:89:in `merge'", "/usr/share/logstash/logstash-core/lib/logstash/settings.rb:138:in `validate_all'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:264:in `execute'", "/usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-0.6.5/lib/clamp/command.rb:67:in `run'", "/usr/share/logstash/logstash-core/lib/logstash/runner.rb:219:in `run'", /usr/share/logstash/vendor/bundle/jruby/2.3.0/gems/clamp-.6.5/lib/clamp/command.rb:132:in `run'", "/usr/share/logstash/lib/bootstrap/environment.rb:67:in `<main>'"]}

#2

The problem is that I did not reinstall xpack in logstash (it is in the other products), so the xpack entries are in logstash.yml, but there are no handlers registered to process them.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.