Settings Log traceId

Good morning,

I don't know if it is a bug but I would like confirm it. I have a configuration of Logs where I added one pattern more.

With this change I can see all the logs, but if i want see the trace of a transaction using the action from the APM menu, i don't have results. I think that could be 2 things:

  • The URL have "traceid:logs" --> I don't know what is it, but if I remove it appears the logs documents.

  • If i go the settings i have a different configuration...

There is any error?

Thanks!!

Hi @Kirtash

What you are trying to accomplish is called log correlation. That correlates the APM traces with the logs that are generated during that Trace.

I'm not sure which agent you're trying to use but here is some reading on the Java Agent.

There's a couple steps to set it up but once you do it's very powerful when you right click and it sends that Trace ID you'll see the exact logs that were generated from the trace.

https://www.elastic.co/guide/en/apm/agent/java/current/log-correlation.html

Hi @stephenb!!

First of all thanks for the answer, the correlation I think that is correct, because the service map is fine.

My doubt is why it takes a setting configuration of logs for default that is not correct :frowning:

Thanks!!

Hi @Kirtash
Actually the default way to look at logs is through the Logs app, there is no filtering applied there and you can decide what you want to filter or search for.

When you are in the APM app when you click to look at logs from a Trace / Transaction you are in a Trace / Transaction context so the behavior is to search / find logs related to that Trace ... That is the expected (default) behavior.

In fact you can get the logs from the Host, Container, Pod etc as well are filtered to the correct context. This allows you to drill in quickly to look for issues, that are related to the Trace.

Hope that makes sense

Hi @stephenb

Sorry, I think that I have explained wrong. The problem isn't traceid. The URL have the param:

sourceId=logs

Was sourceId, not traceid. The Traceid is correct because if I delete the "sourceid" I have all the registers of the transaction with the traceid "X".

Thanks and sorry for my error.