Trace logs in APM does not shows log due to sourceId=logs

Kibana version: 7.8.0

Elasticsearch version: 7.8.0

APM Server version: 7.8.0

APM Agent language and version: Java&Js latest

Browser version: Latest Chrome

Original install method (e.g. download page, yum, deb, from source, etc.) and version: yum

Fresh install or upgraded from other version?: fresh

Description of the problem including expected versus actual behavior. Please include screenshots (if relevant):

I have a problem with showing the logs via trace logs button in apm.

It will generate this query: https://localhost:5601/s/aaa/app/logs/stream?logPosition=(end:%272021-04-08T08:48:23.872Z%27,position:(tiebreaker:0,time:1617868103872),start:%272021-04-08T06:48:23.872Z%27,streamLive:!f)&sourceId=logs&logFilter=(expression:%27trace.id:%22682eccf92aaf2383f5d71508990bd7aa%22%20OR%20682eccf92aaf2383f5d71508990bd7aa%27,kind:kuery)

And result is that I don't have any logs available.

I was able to found that the problem is this part sourceId=logs. If I will delete it from query then everything works as expected.

However, I was not able to found how should I configure it. I tried this setting without success.

Is it a bug in this version or I'm missing something?

Hi there,

Thanks for reaching out. This was fixed in 7.10 via [Logs UI] Remove apollo deps from log link-to routes by weltenwort · Pull Request #74502 · elastic/kibana · GitHub.
If you can upgrade that should fix the issue.