Shield license installation error

security

(Anusha) #1

Hi Team,

I have tried to install shield by the procedure given in this link
https://www.elastic.co/guide/en/shield/current/installing-shield.html

I got installation error as shown in the below image

D:\MyElasticSearch\elasticsearch-1.5.2\bin>plugin -i license
-> Installing license...
Trying https://github.com/null/license/archive/master.zip...
Failed to install license, reason: failed to download out of all possible locati
ons..., use --verbose to get detailed information

Then I tried to download the license externally as per the information provided in the above link

To install Shield on a machine that doesn’t have Internet access:Manually download the appropriate License and Shield binaries:https://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/license/2.1.0/license-2.1.0.ziphttps://download.elastic.co/elasticsearch/release/org/elasticsearch/plugin/shield/2.1.0/shield-2.1.0.zip

Is there any way to solve this?????
Or I need to download them externally??? If Yes
Do I need download license 1.5.2 and shield 1.5.2 as am using elasticsearch 1.5.2, if yes am unable to find the related jars,

can any one hlep me out to solve this issue......


(Jay Modi) #2

Hi Anusha,

Since you are using elasticsearch 1.5.2, you will need to follow the installation instructions for Shield 1.3 as the syntax is different for 2.0+.

For elasticsearch 1.x, we tried to make Shield compatible with many different versions of elasticsearch so Shield 1.3 works for Elasticsearch 1.5.x to 1.7.x. Starting with elasticsearch 2.0, the version of shield and license need to be in sync with the elasticsearch version.


(Anusha) #3

Hi Jay,

Thanks for response, and this working fine [quote="jaymode, post:2, topic:37458"]
installation instructions for Shield 1.3
[/quote]


(system) #4