Single Node Cluster Shard Allocation Problem


(Adwait Joshi) #1

I have a single node cluster and each time I set the replication to 0, I see that after some time the status goes to yellow and the .monitoring* and the .watcher* indexes has unassigned shards. I have to manually set the replication to 0. Is there a global default setting for single nodes to turn off replication for good so that this applies to all indices?


(Christian Dahlqvist) #2

Create an index template that applies to all indices that are created.

{
  "index_patterns": ["*"],
  "settings": {
    "number_of_replicas": 0
  }
}

(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.