Single node ElasticSearch always status yellow


(Johan Landerholm) #1

Hi,
My single node elastic search (5.3.2) system is always yellow because the number_of_replicas is default 1.

I have tried to find out how to change this but failed so far.

  1. I tried using elastic search.yml setting, but this is apparently only a pre-5.x setting.
  2. Tried the default template mapping in the developer tab:
    set /_template/_all { "template" : "*", "settings" : { "number_of_replicas" : "0" }}
    but this does not work.

What is the way to do this?
Why is the default setting 1 instead of 0 ?

/J


(Mert) #2

What is your shards size ?


(David Pilato) #3

What is this command?

set /_template/_all { "template" : "*", "settings" : { "number_of_replicas" : "0" }}

Does not look something I have ever seen.


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.