Snapshots to HDFS


(Gennaro) #1

Hello everyone,

I've been trying to install the HDFS plugin to store snapshots in elasticsearch, but I've bumped into some issues. I've tried installing the latest version of the light plugin (elasticsearch-repository-hdfs-2.2.0.BUILD-20150723.024154-30-light.zip) but it doesn't seem to work.

I have a 2 node test cluster. On the elasticsearch nodes, in /etc/sysconfig/elasticsearch I set the ES_CLASSPATH variable to the output of hadoop classpath from the hdfs test cluster. I then set "export ES_CLASSPATH" in /etc/init.d/elasticsearch on the es test nodes. When I do all of this, I don't see any activity on the hadoop cluster.

However, when I simply install the plugin using bin/plugin -i elasticsearch/elasticsearch-repository-hdfs/2.1.0 I see some life on the hadoop cluster when I tail the logs:

2015-07-20 16:54:29,085 WARN org.apache.hadoop.ipc.Server: Incorrect header or version mismatch from x.x.x.x:39290 got version 4 expected version 7

I believe I'm doing something wrong, but I can't figure out what. I've tried every plugin version to no avail. Any help would be greatly appreciated.

Thanks,
Gennaro


(system) #2