Store Elasticsearch 2.4.1 snapshots to HDFS


(Ant) #1

Hi,

So I've found my definition of definitive and the elastic.io guides definition to be slightly divergent. As such I wondered if anyone here could help me get my backups sorted out?

Origionally I tried to get it to backup to a NAS using a Network File Share however every time I tried to run the backups I it stalled and I got Java blocked errors coming up on screen. Not to worry I thought there is an option to backup to HDFS here and that's a more logical & salable place to put it anyway! The definitive guide was a bit light on how to for this though.

After some searching I found I could install the necessary plugin with the following command
bin/plugin install elasticsearch/elasticsearch-repository-hdfs/2.2.0-hadoop2

When I tried to run this though I got an alert telling me

"ERROR: Plugin [repository-hdfs] is incompatible with Elasticsearch [2.4.1]. Was designed for version [2.2.0]"

seeing 2.2.0 in both the error and the command I executed I thought I saw a fix but there is no version 2.4.1-hadoop2 available so I'm now at a bit of a loss on how to go forward.

Any help would be appreciated.


(Ant) #2

bin/plugin install elasticsearch/elasticsearch-repository-hdfs/2.4.0-hadoop2
does return a file but it reports that it was designed for 2.4.0 and won't work with 2.4.1, looking here

I get the impression a release has yet to be done for 2.4.1 and with 5.0 being the new focus there may never be one?


(James Baiera) #3

@Ant There was no release for 2.4.1 because there were no changes in the 2.x branch to be released at the time. It shouldn't be a problem to cut a 2.4.1 release to remove those warnings. I'll spin one out soon.


(Ant) #4

@james.baiera you sir are a legend.


(James Baiera) #5

@Ant ES-Hadoop 2.4.1 is now available, alongside ES-Hadoop 2.4.2.


(Ant) #6

@james.baiera worked a treat thanks!
backed up on my 2.4.1 box and then rolled out a new 2.4.2 box and it all restored a treat!


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.