Snapshots to S3, only meta files are being created in bucket

I've setup an S3 as a repository for my cluster and when I create a snapshot, it seems to work, though in the bucket the only think I see created is the meta files.

For example if I do this request:

PUT https://mycreds@my_ip:8443/_snapshot/elk_s3_repository/test_snapshot
  "indices": "logstash-2017.11.24",
  "ignore_unavailable": true,
  "include_global_state": false

The snapshot created will eventually has this status:

    "snapshots": [
            "snapshot": "test_snapshot",
            "uuid": "tqOQLw94TsmWcPuWoCUC_A",
            "version_id": 5040099,
            "version": "5.4.0",
            "indices": [
            "state": "SUCCESS",
            "start_time": "2017-12-02T01:33:01.854Z",
            "start_time_in_millis": 1512178381854,
            "end_time": "2017-12-02T01:33:17.189Z",
            "end_time_in_millis": 1512178397189,
            "duration_in_millis": 15335,
            "failures": [],
            "shards": {
                "total": 5,
                "failed": 0,
                "successful": 5

But when I look in the S3 bucket, the only files created are:

snap-tqOQLw94TsmWcPuWoCUC_A.dat .  13.5KB
snap-VI2VFbM5QYOUohR9ZQXCbQ.dat . 246B
meta-I2IjYzR-Tk6YEw-JhbQ-ZQ.dat       13.5K
snap-I2IjYzR-Tk6YEw-JhbQ-ZQ.dat .      246B

I would expect to see much larger files for a 59MB index.. What am I missing?

Normally you should also see a subdirectory named indices IIRC then. 0, 1, 2, 3, 4, then files in it.

I see. I do not have that directory under my base directory.

Weird because it reported:

            "shards": {
                "total": 5,
                "failed": 0,
                "successful": 5

Sorry to ask but are you sure you are looking at the right buckets?
I prefer to double-check.

Can you do that again from scratch?

  • delete the repository
  • remove the S3 container
  • create again the S3 container
  • create the repository
  • snapshot
  • open and list your files available in the container

Can you then share:

  • all the commands you ran
  • your elasticsearch logs

Also which version are you using?

I recreated the S3 Repository by omitting the "base_dir" option, and now all the sub folders and indices are showing up in the the root of the S3 bucket.

So before, files were showing up the base dir, but not all the files, and now ALL the files are showing up in the S3 bucket..

I will proceed for now without trying to specify a base_dir.

What is the version you are using ?

Elasticsearch 5.4.0

1 Like

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.