*** SOLVED *** Forbidden to create Index Pattern in Kibana 7.2

Hi guys,

is there any simple solution how to fix Forbidden Error while creating index pattern in Kibana? I am still getting this error when trying to create a new index pattern.

Error: Forbidden
      _construct@https://hostname/bundles/commons.bundle.js:3:1609071
Wrapper@https://hostname/bundles/commons.bundle.js:3:1608183
KFetchError@https://hostname/bundles/commons.bundle.js:3:1609714
kfetch/<@https://hostname/bundles/commons.bundle.js:3:1605400
run@https://hostname/built_assets/dlls/vendors.bundle.dll.js:92:797402
notify/<@https://hostname/built_assets/dlls/vendors.bundle.dll.js:92:797642
flush@https://hostname/built_assets/dlls/vendors.bundle.dll.js:250:1512804

Thanks

Hi,
May be you have reached high watermark disk? Elasticsearch's index is made read-only and never set back when disk watermark reached high.

To unlock all indexes manually:

curl -XPUT -H "Content-Type: application/json" https://[YOUR_ELASTICSEARCH_ENDPOINT]:9200/_all/_settings -d '{"index.blocks.read_only_allow_delete": null}'

Try this. Else plz post detailed steps as to how you hit this error. It would be easier to debug.

Thanks
Rashmi

Hi,

no, it didn't help. Even i have a lot of disk space. I created a new VM, installed ELK 7.2, configure input/output to process netflow data. Index for that was automatically created in logstash and i can see docs are increasing. Then i went to Kibana to create an index pattern. Kibana recognize it, but when i click on the last step/button to create it i got this error.

@thirty2 would you mind running the following using Dev Tools and providing us the response?

GET _security/user/_privileges

@Brandon_Kobel here you are:

{
"error": {
"root_cause": [
{
"type": "exception",
"reason": "Security must be explicitly enabled when using a [basic] license. Enable security by setting [xpack.security.enabled] to [true] in the elasticsearch.yml file and restart the node."
}
],
"type": "exception",
"reason": "Security must be explicitly enabled when using a [basic] license. Enable security by setting [xpack.security.enabled] to [true] in the elasticsearch.yml file and restart the node."
},
"status": 500
}

When i set this:

xpack.security.enabled: true

in config i am not able to start Kibana then. Getting message in gui, then Kibana is not ready yet.

What esle should be configured?
Thanks

You don't have to enabled security in Elasticsearch to be able to create index patterns in Kibana.

Would you mind running the following queries in Dev Tools and replying with their responses?

GET _cat/aliases
GET _cat/indices
GET _all/_settings

Here you are:

.kibana .kibana_1 - - -
logstash logstash-2019.07.17-000001 - - -

green open .monitoring-es-7-2019.07.21 rRysXjkoQqGsznb-1TcBgg 1 1 146926 224588 192.9mb 96.9mb
green open .monitoring-es-7-2019.07.22 uBmo_NDnQP2wcOPEqcN2Jw 1 1 75324 120 80.5mb 40.3mb
green open .monitoring-kibana-7-2019.07.22 DZFcKeGxTkmeHXjSktF3fw 1 1 3959 0 1.7mb 842.4kb
green open .monitoring-es-7-2019.07.20 R8kXKeCzSsm_qy5mNxcL8g 1 1 129641 190036 134.5mb 84.7mb
green open .kibana_1 X_bMFJWzS-iU6EzFrEXX_A 1 1 5 3 77.8kb 38.9kb
green open .kibana_task_manager C-yrCUgfRj2Ah67Xn-xs5g 1 1 2 0 42.8kb 21.4kb
green open netflow_test1 Mp3aajeNQZyGQ80dXXjy8w 1 1 2512387 0 898mb 359.6mb
green open .monitoring-kibana-7-2019.07.21 oo1OZVx_TCKRmctv2prNzg 1 1 8639 0 3.4mb 1.7mb
green open test P-DgXP1LRkCIyMeekt9C_w 1 1 3 1 16.2kb 6.1kb
green open .monitoring-kibana-7-2019.07.20 R_T46TswRQeehBVybcqoqw 1 1 8640 0 3.3mb 1.6mb
green open logstash-2019.07.17-000001 TRjBlU-dQ9asp2J4fe-Y0g 1 1 217643 0 47.9mb 23.9mb

{
".kibana_task_manager" : {
"settings" : {
"index" : {
"number_of_shards" : "1",
"auto_expand_replicas" : "0-1",
"provided_name" : ".kibana_task_manager",
"creation_date" : "1563432784676",
"number_of_replicas" : "1",
"uuid" : "C-yrCUgfRj2Ah67Xn-xs5g",
"version" : {
"created" : "7020099"
}
}
}
},
".monitoring-es-7-2019.07.22" : {
"settings" : {
"index" : {
"codec" : "best_compression",
"number_of_shards" : "1",
"auto_expand_replicas" : "0-1",
"provided_name" : ".monitoring-es-7-2019.07.22",
"format" : "7",
"creation_date" : "1563753608377",
"number_of_replicas" : "1",
"uuid" : "uBmo_NDnQP2wcOPEqcN2Jw",
"version" : {
"created" : "7020099"
}
}
}
},
"test" : {
"settings" : {
"index" : {
"creation_date" : "1563432198834",
"number_of_shards" : "1",
"number_of_replicas" : "1",
"uuid" : "P-DgXP1LRkCIyMeekt9C_w",
"version" : {
"created" : "7020099"
},
"provided_name" : "test"
}
}
},
".monitoring-kibana-7-2019.07.22" : {
"settings" : {
"index" : {
"codec" : "best_compression",
"number_of_shards" : "1",
"auto_expand_replicas" : "0-1",
"provided_name" : ".monitoring-kibana-7-2019.07.22",
"format" : "7",
"creation_date" : "1563753609027",
"number_of_replicas" : "1",
"uuid" : "DZFcKeGxTkmeHXjSktF3fw",
"version" : {
"created" : "7020099"
}
}
}
},
"netflow_test1" : {
"settings" : {
"index" : {
"creation_date" : "1563350174043",
"number_of_shards" : "1",
"number_of_replicas" : "1",
"uuid" : "Mp3aajeNQZyGQ80dXXjy8w",
"version" : {
"created" : "7020099"
},
"provided_name" : "netflow_test1"
}
}
},
".monitoring-kibana-7-2019.07.21" : {
"settings" : {
"index" : {
"codec" : "best_compression",
"number_of_shards" : "1",
"auto_expand_replicas" : "0-1",
"provided_name" : ".monitoring-kibana-7-2019.07.21",
"format" : "7",
"creation_date" : "1563667209651",
"number_of_replicas" : "1",
"uuid" : "oo1OZVx_TCKRmctv2prNzg",
"version" : {
"created" : "7020099"
}
}
}
},
".monitoring-kibana-7-2019.07.20" : {
"settings" : {
"index" : {
"codec" : "best_compression",
"number_of_shards" : "1",
"auto_expand_replicas" : "0-1",
"provided_name" : ".monitoring-kibana-7-2019.07.20",
"format" : "7",
"creation_date" : "1563580800069",
"number_of_replicas" : "1",
"uuid" : "R_T46TswRQeehBVybcqoqw",
"version" : {
"created" : "7020099"
}
}
}
},
".monitoring-es-7-2019.07.20" : {
"settings" : {
"index" : {
"codec" : "best_compression",
"number_of_shards" : "1",
"auto_expand_replicas" : "0-1",
"provided_name" : ".monitoring-es-7-2019.07.20",
"format" : "7",
"creation_date" : "1563580804940",
"number_of_replicas" : "1",
"uuid" : "R8kXKeCzSsm_qy5mNxcL8g",
"version" : {
"created" : "7020099"
}
}
}
},
".monitoring-es-7-2019.07.21" : {
"settings" : {
"index" : {
"codec" : "best_compression",
"number_of_shards" : "1",
"auto_expand_replicas" : "0-1",
"provided_name" : ".monitoring-es-7-2019.07.21",
"format" : "7",
"creation_date" : "1563667206639",
"number_of_replicas" : "1",
"uuid" : "rRysXjkoQqGsznb-1TcBgg",
"version" : {
"created" : "7020099"
}
}
}
},
".kibana_1" : {
"settings" : {
"index" : {
"number_of_shards" : "1",
"auto_expand_replicas" : "0-1",
"provided_name" : ".kibana_1",
"creation_date" : "1563432784928",
"number_of_replicas" : "1",
"uuid" : "X_bMFJWzS-iU6EzFrEXX_A",
"version" : {
"created" : "7020099"
}
}
}
},
"logstash-2019.07.17-000001" : {
"settings" : {
"index" : {
"refresh_interval" : "5s",
"number_of_shards" : "1",
"provided_name" : "<logstash-{now/d}-000001>",
"creation_date" : "1563362909294",
"number_of_replicas" : "1",
"uuid" : "TRjBlU-dQ9asp2J4fe-Y0g",
"version" : {
"created" : "7020099"
}
}
}
}
}

You don't happen to be putting a reverse-proxy (nginx/apache/etc.) in-front of Kibana/ES, are you? Have you checked your Elasticsearch logs to see if any errors are being thrown?

Yes, i am behind proxy. i can see in the apache log, that when i click on create index in Kibana i get error

AH01797: client denied by server configuration: proxy:https:

Problem Solved. There was misconfiguration in httpd conf. Working when default httpd is listening on port 80 and virtual host is on 443.

Thanks for support

1 Like