[SOLVED] Wirldcard search issue bis


(alexandre) #1

Hi all,

I have opened a Topic in Kibana forum but I didn't find the solution, somebody advise me to ask some help in elasticsearch forum.

If somebody have an idea :

https://discuss.elastic.co/t/wirldcard-search-issue/65347

Thanks in advance,
Alex


(Abdon Pijpelink) #2

By default, wildcard terms are lowercased. Because your short_message field is not_analyzed, a wildcard query with an uppercase I will not match any results (Elasticsearch will search for a lowercase i and not find internal with a lowercase i). Setting lowercase_expanded_terms to false in Kibana's query:queryString:options under Advanced Settings will resolve this.

You also need to change the default value of analyze_wildcard to false for the same reason.

The resulting value for the query:queryString:options setting in Kibana will look like this: { "analyze_wildcard": false, "lowercase_expanded_terms": false}


(alexandre) #3

Thanks a lot !


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.