Spaces issue in pie chart

Hi,
I have an issue with pie chart. Whenever I have a content with space, it is
treating as separate values.
Ex: I have, 'United States'
It is showing two slices in pie chart. One is 'United', and another one,
'States'.

here is my mapping
{
"mappings" : {
"default" : {
"properties" : {
"state" : {"type": "string", "index" : "not_analyzed" }
}
}
}
}
';

may i know where I am doing wrong?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a08c3105-d14e-458b-9edc-64aaf3c2eafb%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.

Hard to say without a full repro.

But you are right, the way for doing this is by setting your field as not analyzed.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfr https://twitter.com/elasticsearchfr | @scrutmydocs https://twitter.com/scrutmydocs

Le 1 déc. 2014 à 15:30, Pavan Elthepu pavan.elthepu@gmail.com a écrit :

Hi,
I have an issue with pie chart. Whenever I have a content with space, it is treating as separate values.
Ex: I have, 'United States'
It is showing two slices in pie chart. One is 'United', and another one, 'States'.

here is my mapping
{
"mappings" : {
"default" : {
"properties" : {
"state" : {"type": "string", "index" : "not_analyzed" }
}
}
}
}
';

may i know where I am doing wrong?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com mailto:elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/a08c3105-d14e-458b-9edc-64aaf3c2eafb%40googlegroups.com https://groups.google.com/d/msgid/elasticsearch/a08c3105-d14e-458b-9edc-64aaf3c2eafb%40googlegroups.com?utm_medium=email&utm_source=footer.
For more options, visit https://groups.google.com/d/optout https://groups.google.com/d/optout.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/B9990667-AA86-4DE3-AD47-289858A01C87%40pilato.fr.
For more options, visit https://groups.google.com/d/optout.

Here is my mapping:
{
"mappings" : {
"default" : {
"properties" : {
"state" : {"type": "string", "index" : "not_analyzed" }
}
}
}
}
';

On Monday, December 1, 2014 8:00:01 PM UTC+5:30, Pavan Elthepu wrote:

Hi,
I have an issue with pie chart. Whenever I have a content with space, it
is treating as separate values.
Ex: I have, 'United States'
It is showing two slices in pie chart. One is 'United', and another one,
'States'.

here is my mapping
{
"mappings" : {
"default" : {
"properties" : {
"state" : {"type": "string", "index" : "not_analyzed" }
}
}
}
}
';

may i know where I am doing wrong?

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/f3779d74-53c6-499a-8826-bb7fe581669f%40googlegroups.com.
For more options, visit https://groups.google.com/d/optout.