Spring elastic search and configuration for Mappings and _settings files


(Ramdev Wudali) #1

Hi All:
I am trying to index a set of documents with the following mapping :
{
"NewTitles": {
"properties": {
"DOC_ID": {
"type":"string"
},
"TITLE": {
"type": "multi_field",
"fields" : {
"TITLE" : {
"type" : "string"
},
"sortable" : {
"type" : "string",
"index" : "not_analyzed"
},
"autocomplete" : {
"type" : "string",
"index_analyzer" : "shingle_analyzer"
}
}
}
}
}
}

(which resides in the src/main/es/experiment folder in my project)

and there is a _settings.json file which defines the shingle_analyzer like
so :

{
"index" : {
"analysis": {
"filter": {
"shingle_filter": {
"type": "shingle",
"min_shingle_size": 2,
"max_shingle_size": 5
}
},
"analyzer": {
"shingle_analyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"lowercase",
"shingle_filter"
]
}
}
}
}
}

I am initializing the Elasticsearch client using the spring elastic search
like so :

<util:map id="esProperties">
    <entry key="cluster.name" value="elasticsearch-experiment" />
</util:map>

<elasticsearch:client id="esClient2"  mappings="experiment/NewTitles"
                      esNodes="elasticsearch.server:8300"
                      forceMapping="true" properties="esProperties"/>

The elastic Search instance already has the index : experiment and Type :
Titles

When I run my app to index some new content, I get the an error during
Spring initialization, :

12:47:03.044 CST INFO [main ]
f.p.s.e.ElasticsearchTransportClientFactoryBean - Starting ElasticSearch
client
12:47:03.753 CST INFO [main ] org.elasticsearch.plugins -
[Ringleader] loaded [], sites []
Exception in thread "main"
org.springframework.beans.factory.BeanCreationException: Error creating
bean with name 'esClient2': Invocation of init method failed; nested
exception is org.elasticsearch.transport.TransportSerializationException:
Failed to deserialize exception response from stream

Upon checking the server as to the actual error :

[2014-01-03 12:47:08,554][DEBUG][action.admin.indices.mapping.put]
[Overkill] failed to put mappings on indices [[experiment]], type
[NewTitles]
org.elasticsearch.index.mapper.MapperParsingException: Analyzer
[shingle_analyzer] not found for field [autocomplete]
at
org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
at
org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
at
org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:133)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:383)
at
org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:399)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:298)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
"el

Does anyone have any idea what might be going on that would cause the
problem ? I have the _settings.json, and NewTitles.json both in the class
path and same folder. (as mentioned above).

Any help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2b5610bc-5df1-41df-8e75-d3fecbca4a26%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #2

Any chance you are mixing elasticsearch versions between node and client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 20:16, Ramdev Wudali agastya71@gmail.com a écrit :

Hi All:
I am trying to index a set of documents with the following mapping :
{
"NewTitles": {
"properties": {
"DOC_ID": {
"type":"string"
},
"TITLE": {
"type": "multi_field",
"fields" : {
"TITLE" : {
"type" : "string"
},
"sortable" : {
"type" : "string",
"index" : "not_analyzed"
},
"autocomplete" : {
"type" : "string",
"index_analyzer" : "shingle_analyzer"
}
}
}
}
}
}

(which resides in the src/main/es/experiment folder in my project)

and there is a _settings.json file which defines the shingle_analyzer like so :

{
"index" : {
"analysis": {
"filter": {
"shingle_filter": {
"type": "shingle",
"min_shingle_size": 2,
"max_shingle_size": 5
}
},
"analyzer": {
"shingle_analyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"lowercase",
"shingle_filter"
]
}
}
}
}
}

I am initializing the Elasticsearch client using the spring elastic search like so :

<util:map id="esProperties">
    <entry key="cluster.name" value="elasticsearch-experiment" />
</util:map>

<elasticsearch:client id="esClient2"  mappings="experiment/NewTitles"
                      esNodes="elasticsearch.server:8300"
                      forceMapping="true" properties="esProperties"/>

The elastic Search instance already has the index : experiment and Type : Titles

When I run my app to index some new content, I get the an error during Spring initialization, :

12:47:03.044 CST INFO [main ] f.p.s.e.ElasticsearchTransportClientFactoryBean - Starting ElasticSearch client
12:47:03.753 CST INFO [main ] org.elasticsearch.plugins - [Ringleader] loaded [], sites []
Exception in thread "main" org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'esClient2': Invocation of init method failed; nested exception is org.elasticsearch.transport.TransportSerializationException: Failed to deserialize exception response from stream

Upon checking the server as to the actual error :

[2014-01-03 12:47:08,554][DEBUG][action.admin.indices.mapping.put] [Overkill] failed to put mappings on indices [[experiment]], type [NewTitles]
org.elasticsearch.index.mapper.MapperParsingException: Analyzer [shingle_analyzer] not found for field [autocomplete]
at org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
at org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
at org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:133)
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:383)
at org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:399)
at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:298)
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
"el

Does anyone have any idea what might be going on that would cause the problem ? I have the _settings.json, and NewTitles.json both in the class path and same folder. (as mentioned above).

Any help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2b5610bc-5df1-41df-8e75-d3fecbca4a26%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8668EBCC-9952-4FB9-ACDB-85535F71C60C%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.


(Ramdev Wudali) #3

Hi David:
Thanks for the speedy response. Here is an update to my problem. I was
trying to create a different type within the same index. (Index:
experiment, type : Titles and I was trying to create Type : NewTitles ) I
am not sure if this has any bearing on the problem.

After posting the question on the group, I went ahead and created a
separate index (experiment2) and within this new index, I created the
Type: NewTitles.

When I ran my application, there was no problems during the Spring elastic
search client initialization.

This basically tells me there is a conflict in creation of a new Type under
an existing index. (I am not able to figure out why there is a conflict).

And I am not mixing versions of ElasticSearch between client and node.
(both using 0.90.5)

hope this helps

Thanks

Ramdev

See my vizify bio!
[image: Ramdev Wudali's Visual
Thumbprint]https://www.vizify.com/es/5015811a501a700002000177

On Fri, Jan 3, 2014 at 2:29 PM, David Pilato david@pilato.fr wrote:

Any chance you are mixing elasticsearch versions between node and client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 20:16, Ramdev Wudali agastya71@gmail.com a écrit :

Hi All:
I am trying to index a set of documents with the following mapping :
{
"NewTitles": {
"properties": {
"DOC_ID": {
"type":"string"
},
"TITLE": {
"type": "multi_field",
"fields" : {
"TITLE" : {
"type" : "string"
},
"sortable" : {
"type" : "string",
"index" : "not_analyzed"
},
"autocomplete" : {
"type" : "string",
"index_analyzer" : "shingle_analyzer"
}
}
}
}
}
}

(which resides in the src/main/es/experiment folder in my project)

and there is a _settings.json file which defines the shingle_analyzer
like so :

{
"index" : {
"analysis": {
"filter": {
"shingle_filter": {
"type": "shingle",
"min_shingle_size": 2,
"max_shingle_size": 5
}
},
"analyzer": {
"shingle_analyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"lowercase",
"shingle_filter"
]
}
}
}
}
}

I am initializing the Elasticsearch client using the spring elastic search
like so :

<util:map id="esProperties">
    <entry key="cluster.name" value="elasticsearch-experiment" />
</util:map>

<elasticsearch:client id="esClient2"  mappings="experiment/NewTitles"
                      esNodes="elasticsearch.server:8300"
                      forceMapping="true" properties="esProperties"/>

The elastic Search instance already has the index : experiment and Type :
Titles

When I run my app to index some new content, I get the an error during
Spring initialization, :

12:47:03.044 CST INFO [main ]
f.p.s.e.ElasticsearchTransportClientFactoryBean - Starting ElasticSearch
client
12:47:03.753 CST INFO [main ] org.elasticsearch.plugins -
[Ringleader] loaded [], sites []
Exception in thread "main"
org.springframework.beans.factory.BeanCreationException: Error creating
bean with name 'esClient2': Invocation of init method failed; nested
exception is org.elasticsearch.transport.TransportSerializationException:
Failed to deserialize exception response from stream

Upon checking the server as to the actual error :

[2014-01-03 12:47:08,554][DEBUG][action.admin.indices.mapping.put]
[Overkill] failed to put mappings on indices [[experiment]], type
[NewTitles]
org.elasticsearch.index.mapper.MapperParsingException: Analyzer
[shingle_analyzer] not found for field [autocomplete]
at
org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
at
org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
at
org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:133)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:383)
at
org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:399)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:298)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
"el

Does anyone have any idea what might be going on that would cause the
problem ? I have the _settings.json, and NewTitles.json both in the class
path and same folder. (as mentioned above).

Any help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2b5610bc-5df1-41df-8e75-d3fecbca4a26%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8668EBCC-9952-4FB9-ACDB-85535F71C60C%40pilato.fr
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7h_Hs8fHhLPm2mO0U0mZBTfHJGPd0zt71vmrkgvQtFkFA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #4

Is it a typo?

esNodes="elasticsearch.server:8300"

Should be 9300, right?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 21:35, Ramdev Wudali agastya71@gmail.com a écrit :

Hi David:
Thanks for the speedy response. Here is an update to my problem. I was trying to create a different type within the same index. (Index: experiment, type : Titles and I was trying to create Type : NewTitles ) I am not sure if this has any bearing on the problem.

After posting the question on the group, I went ahead and created a separate index (experiment2) and within this new index, I created the Type: NewTitles.

When I ran my application, there was no problems during the Spring elastic search client initialization.

This basically tells me there is a conflict in creation of a new Type under an existing index. (I am not able to figure out why there is a conflict).

And I am not mixing versions of ElasticSearch between client and node. (both using 0.90.5)

hope this helps

Thanks

Ramdev

See my vizify bio!

On Fri, Jan 3, 2014 at 2:29 PM, David Pilato david@pilato.fr wrote:

Any chance you are mixing elasticsearch versions between node and client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 20:16, Ramdev Wudali agastya71@gmail.com a écrit :

Hi All:
I am trying to index a set of documents with the following mapping :
{
"NewTitles": {
"properties": {
"DOC_ID": {
"type":"string"
},
"TITLE": {
"type": "multi_field",
"fields" : {
"TITLE" : {
"type" : "string"
},
"sortable" : {
"type" : "string",
"index" : "not_analyzed"
},
"autocomplete" : {
"type" : "string",
"index_analyzer" : "shingle_analyzer"
}
}
}
}
}
}

(which resides in the src/main/es/experiment folder in my project)

and there is a _settings.json file which defines the shingle_analyzer like so :

{
"index" : {
"analysis": {
"filter": {
"shingle_filter": {
"type": "shingle",
"min_shingle_size": 2,
"max_shingle_size": 5
}
},
"analyzer": {
"shingle_analyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"lowercase",
"shingle_filter"
]
}
}
}
}
}

I am initializing the Elasticsearch client using the spring elastic search like so :

<util:map id="esProperties">
    <entry key="cluster.name" value="elasticsearch-experiment" />
</util:map>

<elasticsearch:client id="esClient2"  mappings="experiment/NewTitles"
                      esNodes="elasticsearch.server:8300"
                      forceMapping="true" properties="esProperties"/>

The elastic Search instance already has the index : experiment and Type : Titles

When I run my app to index some new content, I get the an error during Spring initialization, :

12:47:03.044 CST INFO [main ] f.p.s.e.ElasticsearchTransportClientFactoryBean - Starting ElasticSearch client
12:47:03.753 CST INFO [main ] org.elasticsearch.plugins - [Ringleader] loaded [], sites []
Exception in thread "main" org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'esClient2': Invocation of init method failed; nested exception is org.elasticsearch.transport.TransportSerializationException: Failed to deserialize exception response from stream

Upon checking the server as to the actual error :

[2014-01-03 12:47:08,554][DEBUG][action.admin.indices.mapping.put] [Overkill] failed to put mappings on indices [[experiment]], type [NewTitles]
org.elasticsearch.index.mapper.MapperParsingException: Analyzer [shingle_analyzer] not found for field [autocomplete]
at org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
at org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
at org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:133)
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:383)
at org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:399)
at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:298)
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
"el

Does anyone have any idea what might be going on that would cause the problem ? I have the _settings.json, and NewTitles.json both in the class path and same folder. (as mentioned above).

Any help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2b5610bc-5df1-41df-8e75-d3fecbca4a26%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8668EBCC-9952-4FB9-ACDB-85535F71C60C%40pilato.fr.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7h_Hs8fHhLPm2mO0U0mZBTfHJGPd0zt71vmrkgvQtFkFA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/E725DE0D-17DD-4266-A0A8-FB6735D0CA36%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.


(Ramdev Wudali) #5

Hi David:
I setup the config to run on port 8200 and 8300 (instead of default 9200
and 9300 as they were taken up by tomcat)

See my vizify bio!
[image: Ramdev Wudali's Visual
Thumbprint]https://www.vizify.com/es/5015811a501a700002000177

On Fri, Jan 3, 2014 at 2:38 PM, David Pilato david@pilato.fr wrote:

Is it a typo?

esNodes="elasticsearch.server:8300"

Should be 9300, right?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 21:35, Ramdev Wudali agastya71@gmail.com a écrit :

Hi David:
Thanks for the speedy response. Here is an update to my problem. I was
trying to create a different type within the same index. (Index:
experiment, type : Titles and I was trying to create Type : NewTitles ) I
am not sure if this has any bearing on the problem.

After posting the question on the group, I went ahead and created a
separate index (experiment2) and within this new index, I created the
Type: NewTitles.

When I ran my application, there was no problems during the Spring elastic
search client initialization.

This basically tells me there is a conflict in creation of a new Type
under an existing index. (I am not able to figure out why there is a
conflict).

And I am not mixing versions of ElasticSearch between client and node.
(both using 0.90.5)

hope this helps

Thanks

Ramdev

See my vizify bio!
[image: Ramdev Wudali's Visual Thumbprint]https://www.vizify.com/es/5015811a501a700002000177

On Fri, Jan 3, 2014 at 2:29 PM, David Pilato david@pilato.fr wrote:

Any chance you are mixing elasticsearch versions between node and client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 20:16, Ramdev Wudali agastya71@gmail.com a écrit :

Hi All:
I am trying to index a set of documents with the following mapping :
{
"NewTitles": {
"properties": {
"DOC_ID": {
"type":"string"
},
"TITLE": {
"type": "multi_field",
"fields" : {
"TITLE" : {
"type" : "string"
},
"sortable" : {
"type" : "string",
"index" : "not_analyzed"
},
"autocomplete" : {
"type" : "string",
"index_analyzer" : "shingle_analyzer"
}
}
}
}
}
}

(which resides in the src/main/es/experiment folder in my project)

and there is a _settings.json file which defines the shingle_analyzer
like so :

{
"index" : {
"analysis": {
"filter": {
"shingle_filter": {
"type": "shingle",
"min_shingle_size": 2,
"max_shingle_size": 5
}
},
"analyzer": {
"shingle_analyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"lowercase",
"shingle_filter"
]
}
}
}
}
}

I am initializing the Elasticsearch client using the spring elastic
search like so :

<util:map id="esProperties">
    <entry key="cluster.name" value="elasticsearch-experiment" />
</util:map>

<elasticsearch:client id="esClient2"  mappings="experiment/NewTitles"
                      esNodes="elasticsearch.server:8300"
                      forceMapping="true" properties="esProperties"/>

The elastic Search instance already has the index : experiment and Type :
Titles

When I run my app to index some new content, I get the an error during
Spring initialization, :

12:47:03.044 CST INFO [main ]
f.p.s.e.ElasticsearchTransportClientFactoryBean - Starting ElasticSearch
client
12:47:03.753 CST INFO [main ] org.elasticsearch.plugins -
[Ringleader] loaded [], sites []
Exception in thread "main"
org.springframework.beans.factory.BeanCreationException: Error creating
bean with name 'esClient2': Invocation of init method failed; nested
exception is org.elasticsearch.transport.TransportSerializationException:
Failed to deserialize exception response from stream

Upon checking the server as to the actual error :

[2014-01-03 12:47:08,554][DEBUG][action.admin.indices.mapping.put]
[Overkill] failed to put mappings on indices [[experiment]], type
[NewTitles]
org.elasticsearch.index.mapper.MapperParsingException: Analyzer
[shingle_analyzer] not found for field [autocomplete]
at
org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
at
org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
at
org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:133)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:383)
at
org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:399)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:298)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
"el

Does anyone have any idea what might be going on that would cause the
problem ? I have the _settings.json, and NewTitles.json both in the class
path and same folder. (as mentioned above).

Any help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2b5610bc-5df1-41df-8e75-d3fecbca4a26%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8668EBCC-9952-4FB9-ACDB-85535F71C60C%40pilato.fr
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7h_Hs8fHhLPm2mO0U0mZBTfHJGPd0zt71vmrkgvQtFkFA%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/E725DE0D-17DD-4266-A0A8-FB6735D0CA36%40pilato.fr
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7gvMFov5rXfXBB10oShbskCzCcnYY4dKQ6rMczg41mD-g%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #6

Could you share your project or gist your files and source code?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 22:08, Ramdev Wudali agastya71@gmail.com a écrit :

Hi David:
I setup the config to run on port 8200 and 8300 (instead of default 9200 and 9300 as they were taken up by tomcat)

See my vizify bio!

On Fri, Jan 3, 2014 at 2:38 PM, David Pilato david@pilato.fr wrote:

Is it a typo?

esNodes="elasticsearch.server:8300"

Should be 9300, right?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 21:35, Ramdev Wudali agastya71@gmail.com a écrit :

Hi David:
Thanks for the speedy response. Here is an update to my problem. I was trying to create a different type within the same index. (Index: experiment, type : Titles and I was trying to create Type : NewTitles ) I am not sure if this has any bearing on the problem.

After posting the question on the group, I went ahead and created a separate index (experiment2) and within this new index, I created the Type: NewTitles.

When I ran my application, there was no problems during the Spring elastic search client initialization.

This basically tells me there is a conflict in creation of a new Type under an existing index. (I am not able to figure out why there is a conflict).

And I am not mixing versions of ElasticSearch between client and node. (both using 0.90.5)

hope this helps

Thanks

Ramdev

See my vizify bio!

On Fri, Jan 3, 2014 at 2:29 PM, David Pilato david@pilato.fr wrote:

Any chance you are mixing elasticsearch versions between node and client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 20:16, Ramdev Wudali agastya71@gmail.com a écrit :

Hi All:
I am trying to index a set of documents with the following mapping :
{
"NewTitles": {
"properties": {
"DOC_ID": {
"type":"string"
},
"TITLE": {
"type": "multi_field",
"fields" : {
"TITLE" : {
"type" : "string"
},
"sortable" : {
"type" : "string",
"index" : "not_analyzed"
},
"autocomplete" : {
"type" : "string",
"index_analyzer" : "shingle_analyzer"
}
}
}
}
}
}

(which resides in the src/main/es/experiment folder in my project)

and there is a _settings.json file which defines the shingle_analyzer like so :

{
"index" : {
"analysis": {
"filter": {
"shingle_filter": {
"type": "shingle",
"min_shingle_size": 2,
"max_shingle_size": 5
}
},
"analyzer": {
"shingle_analyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"lowercase",
"shingle_filter"
]
}
}
}
}
}

I am initializing the Elasticsearch client using the spring elastic search like so :

<util:map id="esProperties">
    <entry key="cluster.name" value="elasticsearch-experiment" />
</util:map>

<elasticsearch:client id="esClient2"  mappings="experiment/NewTitles"
                      esNodes="elasticsearch.server:8300"
                      forceMapping="true" properties="esProperties"/>

The elastic Search instance already has the index : experiment and Type : Titles

When I run my app to index some new content, I get the an error during Spring initialization, :

12:47:03.044 CST INFO [main ] f.p.s.e.ElasticsearchTransportClientFactoryBean - Starting ElasticSearch client
12:47:03.753 CST INFO [main ] org.elasticsearch.plugins - [Ringleader] loaded [], sites []
Exception in thread "main" org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'esClient2': Invocation of init method failed; nested exception is org.elasticsearch.transport.TransportSerializationException: Failed to deserialize exception response from stream

Upon checking the server as to the actual error :

[2014-01-03 12:47:08,554][DEBUG][action.admin.indices.mapping.put] [Overkill] failed to put mappings on indices [[experiment]], type [NewTitles]
org.elasticsearch.index.mapper.MapperParsingException: Analyzer [shingle_analyzer] not found for field [autocomplete]
at org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
at org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
at org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:133)
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:383)
at org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:399)
at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:298)
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
"el

Does anyone have any idea what might be going on that would cause the problem ? I have the _settings.json, and NewTitles.json both in the class path and same folder. (as mentioned above).

Any help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2b5610bc-5df1-41df-8e75-d3fecbca4a26%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8668EBCC-9952-4FB9-ACDB-85535F71C60C%40pilato.fr.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7h_Hs8fHhLPm2mO0U0mZBTfHJGPd0zt71vmrkgvQtFkFA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/E725DE0D-17DD-4266-A0A8-FB6735D0CA36%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7gvMFov5rXfXBB10oShbskCzCcnYY4dKQ6rMczg41mD-g%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/C5F69B12-DDC1-4515-B228-F35562D0F250%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.


(Ramdev Wudali) #7

Hi David :
Sorry for the delay in my response.. (the weekend chores took over).
Here is my project (a tgz archive file) its a maven project so you should
due able to import it into your IDE of choice (I have used IntelliJ, So you
may find some of those artifacts as well).

I have not included any data. (the data format is just Strings(titles) one
per line). The path is specified in the spring config file. that is
included in the resources folder.

Please do let me know if you do find something…

Thanks

Ramdev

See my vizify bio!
[image: Ramdev Wudali's Visual
Thumbprint]https://www.vizify.com/es/5015811a501a700002000177

On Fri, Jan 3, 2014 at 3:20 PM, David Pilato david@pilato.fr wrote:

Could you share your project or gist your files and source code?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 22:08, Ramdev Wudali agastya71@gmail.com a écrit :

Hi David:
I setup the config to run on port 8200 and 8300 (instead of default
9200 and 9300 as they were taken up by tomcat)

See my vizify bio!
[image: Ramdev Wudali's Visual Thumbprint]https://www.vizify.com/es/5015811a501a700002000177

On Fri, Jan 3, 2014 at 2:38 PM, David Pilato david@pilato.fr wrote:

Is it a typo?

esNodes="elasticsearch.server:8300"

Should be 9300, right?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 21:35, Ramdev Wudali agastya71@gmail.com a écrit :

Hi David:
Thanks for the speedy response. Here is an update to my problem. I was
trying to create a different type within the same index. (Index:
experiment, type : Titles and I was trying to create Type : NewTitles ) I
am not sure if this has any bearing on the problem.

After posting the question on the group, I went ahead and created a
separate index (experiment2) and within this new index, I created the
Type: NewTitles.

When I ran my application, there was no problems during the Spring
elastic search client initialization.

This basically tells me there is a conflict in creation of a new Type
under an existing index. (I am not able to figure out why there is a
conflict).

And I am not mixing versions of ElasticSearch between client and node.
(both using 0.90.5)

hope this helps

Thanks

Ramdev

See my vizify bio!
[image: Ramdev Wudali's Visual Thumbprint]https://www.vizify.com/es/5015811a501a700002000177

On Fri, Jan 3, 2014 at 2:29 PM, David Pilato david@pilato.fr wrote:

Any chance you are mixing elasticsearch versions between node and client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 20:16, Ramdev Wudali agastya71@gmail.com a écrit :

Hi All:
I am trying to index a set of documents with the following mapping :
{
"NewTitles": {
"properties": {
"DOC_ID": {
"type":"string"
},
"TITLE": {
"type": "multi_field",
"fields" : {
"TITLE" : {
"type" : "string"
},
"sortable" : {
"type" : "string",
"index" : "not_analyzed"
},
"autocomplete" : {
"type" : "string",
"index_analyzer" : "shingle_analyzer"
}
}
}
}
}
}

(which resides in the src/main/es/experiment folder in my project)

and there is a _settings.json file which defines the shingle_analyzer
like so :

{
"index" : {
"analysis": {
"filter": {
"shingle_filter": {
"type": "shingle",
"min_shingle_size": 2,
"max_shingle_size": 5
}
},
"analyzer": {
"shingle_analyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"lowercase",
"shingle_filter"
]
}
}
}
}
}

I am initializing the Elasticsearch client using the spring elastic
search like so :

<util:map id="esProperties">
    <entry key="cluster.name" value="elasticsearch-experiment" />
</util:map>

<elasticsearch:client id="esClient2"  mappings="experiment/NewTitles"
                      esNodes="elasticsearch.server:8300"
                      forceMapping="true" properties="esProperties"/>

The elastic Search instance already has the index : experiment and Type
: Titles

When I run my app to index some new content, I get the an error during
Spring initialization, :

12:47:03.044 CST INFO [main ]
f.p.s.e.ElasticsearchTransportClientFactoryBean - Starting ElasticSearch
client
12:47:03.753 CST INFO [main ] org.elasticsearch.plugins -
[Ringleader] loaded [], sites []
Exception in thread "main"
org.springframework.beans.factory.BeanCreationException: Error creating
bean with name 'esClient2': Invocation of init method failed; nested
exception is org.elasticsearch.transport.TransportSerializationException:
Failed to deserialize exception response from stream

Upon checking the server as to the actual error :

[2014-01-03 12:47:08,554][DEBUG][action.admin.indices.mapping.put]
[Overkill] failed to put mappings on indices [[experiment]], type
[NewTitles]
org.elasticsearch.index.mapper.MapperParsingException: Analyzer
[shingle_analyzer] not found for field [autocomplete]
at
org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
at
org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
at
org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:133)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:383)
at
org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:399)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:298)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
"el

Does anyone have any idea what might be going on that would cause the
problem ? I have the _settings.json, and NewTitles.json both in the class
path and same folder. (as mentioned above).

Any help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2b5610bc-5df1-41df-8e75-d3fecbca4a26%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8668EBCC-9952-4FB9-ACDB-85535F71C60C%40pilato.fr
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7h_Hs8fHhLPm2mO0U0mZBTfHJGPd0zt71vmrkgvQtFkFA%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/E725DE0D-17DD-4266-A0A8-FB6735D0CA36%40pilato.fr
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7gvMFov5rXfXBB10oShbskCzCcnYY4dKQ6rMczg41mD-g%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/C5F69B12-DDC1-4515-B228-F35562D0F250%40pilato.fr
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7itNarJhn_5mpiAUDGqUYPnFpERPpCMHUEfsOaq0QNcFQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(David Pilato) #8

Your configuration looks good to me.

I modified your spring file to add a node and change server location:

<elasticsearch:node properties="esProperties" name="node" />

<elasticsearch:client id="esClient2"  mappings="experiment2/NewTitles"
                      esNodes="localhost:9300"
                      forceMapping="true" properties="esProperties"/>

I started you main() and the factory starts as expected.
No error seen.

Not sure where your issue came from.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet | @elasticsearchfr

Le 6 janvier 2014 at 15:18:42, Ramdev Wudali (agastya71@gmail.com) a écrit:

Hi David :
Sorry for the delay in my response.. (the weekend chores took over). Here is my project (a tgz archive file) its a maven project so you should due able to import it into your IDE of choice (I have used IntelliJ, So you may find some of those artifacts as well).

I have not included any data. (the data format is just Strings(titles) one per line). The path is specified in the spring config file. that is included in the resources folder.

Please do let me know if you do find something…

Thanks

Ramdev

See my vizify bio!

On Fri, Jan 3, 2014 at 3:20 PM, David Pilato david@pilato.fr wrote:
Could you share your project or gist your files and source code?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 22:08, Ramdev Wudali agastya71@gmail.com a écrit :

Hi David:
I setup the config to run on port 8200 and 8300 (instead of default 9200 and 9300 as they were taken up by tomcat)

See my vizify bio!

On Fri, Jan 3, 2014 at 2:38 PM, David Pilato david@pilato.fr wrote:
Is it a typo?

esNodes="elasticsearch.server:8300"

Should be 9300, right?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 21:35, Ramdev Wudali agastya71@gmail.com a écrit :

Hi David:
Thanks for the speedy response. Here is an update to my problem. I was trying to create a different type within the same index. (Index: experiment, type : Titles and I was trying to create Type : NewTitles ) I am not sure if this has any bearing on the problem.

After posting the question on the group, I went ahead and created a separate index (experiment2) and within this new index, I created the Type: NewTitles.

When I ran my application, there was no problems during the Spring elastic search client initialization.

This basically tells me there is a conflict in creation of a new Type under an existing index. (I am not able to figure out why there is a conflict).

And I am not mixing versions of ElasticSearch between client and node. (both using 0.90.5)

hope this helps

Thanks

Ramdev

See my vizify bio!

On Fri, Jan 3, 2014 at 2:29 PM, David Pilato david@pilato.fr wrote:
Any chance you are mixing elasticsearch versions between node and client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 20:16, Ramdev Wudali agastya71@gmail.com a écrit :

Hi All:
I am trying to index a set of documents with the following mapping :
{
"NewTitles": {
"properties": {
"DOC_ID": {
"type":"string"
},
"TITLE": {
"type": "multi_field",
"fields" : {
"TITLE" : {
"type" : "string"
},
"sortable" : {
"type" : "string",
"index" : "not_analyzed"
},
"autocomplete" : {
"type" : "string",
"index_analyzer" : "shingle_analyzer"
}
}
}
}
}
}

(which resides in the src/main/es/experiment folder in my project)

and there is a _settings.json file which defines the shingle_analyzer like so :

{
"index" : {
"analysis": {
"filter": {
"shingle_filter": {
"type": "shingle",
"min_shingle_size": 2,
"max_shingle_size": 5
}
},
"analyzer": {
"shingle_analyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"lowercase",
"shingle_filter"
]
}
}
}
}
}

I am initializing the Elasticsearch client using the spring elastic search like so :

<util:map id="esProperties">
    <entry key="cluster.name" value="elasticsearch-experiment" />
</util:map>

<elasticsearch:client id="esClient2"  mappings="experiment/NewTitles"
                      esNodes="elasticsearch.server:8300"
                      forceMapping="true" properties="esProperties"/>

The elastic Search instance already has the index : experiment and Type : Titles

When I run my app to index some new content, I get the an error during Spring initialization, :

12:47:03.044 CST INFO [main ] f.p.s.e.ElasticsearchTransportClientFactoryBean - Starting ElasticSearch client
12:47:03.753 CST INFO [main ] org.elasticsearch.plugins - [Ringleader] loaded [], sites []
Exception in thread "main" org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'esClient2': Invocation of init method failed; nested exception is org.elasticsearch.transport.TransportSerializationException: Failed to deserialize exception response from stream

Upon checking the server as to the actual error :

[2014-01-03 12:47:08,554][DEBUG][action.admin.indices.mapping.put] [Overkill] failed to put mappings on indices [[experiment]], type [NewTitles]
org.elasticsearch.index.mapper.MapperParsingException: Analyzer [shingle_analyzer] not found for field [autocomplete]
at org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
at org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
at org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:133)
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
at org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:383)
at org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:399)
at org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:298)
at org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
"el

Does anyone have any idea what might be going on that would cause the problem ? I have the _settings.json, and NewTitles.json both in the class path and same folder. (as mentioned above).

Any help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/2b5610bc-5df1-41df-8e75-d3fecbca4a26%40googlegroups.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/8668EBCC-9952-4FB9-ACDB-85535F71C60C%40pilato.fr.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7h_Hs8fHhLPm2mO0U0mZBTfHJGPd0zt71vmrkgvQtFkFA%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/E725DE0D-17DD-4266-A0A8-FB6735D0CA36%40pilato.fr.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7gvMFov5rXfXBB10oShbskCzCcnYY4dKQ6rMczg41mD-g%40mail.gmail.com.

For more options, visit https://groups.google.com/groups/opt_out.

You received this message because you are subscribed to a topic in the Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/C5F69B12-DDC1-4515-B228-F35562D0F250%40pilato.fr.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7itNarJhn_5mpiAUDGqUYPnFpERPpCMHUEfsOaq0QNcFQ%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.

  • exlastic_example.tgz, 24 KB

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/etPan.52ce6360.77ae35eb.1449b%40MacBook-Air-de-David.local.
For more options, visit https://groups.google.com/groups/opt_out.


(Ramdev Wudali) #9

Hi David:
Now that you have experiment2 Index created with Type NewTitles, With
the same spring configuration, Can you create a different Type in the same
Index, for example : experiment2/OldTitles ?

If you do not have any issues creating a new Type under and existing Index
without deleting the data in the previous Type, I would like to know how
you go about it. (that is the problem I am trying to resolve)

Thanks much

Ramdev

See my vizify bio!
[image: Ramdev Wudali's Visual
Thumbprint]https://www.vizify.com/es/5015811a501a700002000177

On Thu, Jan 9, 2014 at 2:52 AM, David Pilato david@pilato.fr wrote:

Your configuration looks good to me.

I modified your spring file to add a node and change server location:

<elasticsearch:node properties="esProperties" name="node" />

<elasticsearch:client id="esClient2"  mappings="experiment2/NewTitles"
                      esNodes="localhost:9300"
                      forceMapping="true" properties="esProperties"/>

I started you main() and the factory starts as expected.
No error seen.

Not sure where your issue came from.

--
David Pilato | Technical Advocate | Elasticsearch.com
@dadoonet https://twitter.com/dadoonet | @elasticsearchfrhttps://twitter.com/elasticsearchfr

Le 6 janvier 2014 at 15:18:42, Ramdev Wudali (agastya71@gmail.com//agastya71@gmail.com)
a écrit:

Hi David :
Sorry for the delay in my response.. (the weekend chores took over).
Here is my project (a tgz archive file) its a maven project so you should
due able to import it into your IDE of choice (I have used IntelliJ, So you
may find some of those artifacts as well).

I have not included any data. (the data format is just Strings(titles)
one per line). The path is specified in the spring config file. that is
included in the resources folder.

Please do let me know if you do find something…

Thanks

Ramdev

See my vizify bio!
[image: Ramdev Wudali's Visual Thumbprint]https://www.vizify.com/es/5015811a501a700002000177

On Fri, Jan 3, 2014 at 3:20 PM, David Pilato david@pilato.fr wrote:

Could you share your project or gist your files and source code?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 22:08, Ramdev Wudali agastya71@gmail.com a écrit :

Hi David:
I setup the config to run on port 8200 and 8300 (instead of default
9200 and 9300 as they were taken up by tomcat)

See my vizify bio!
[image: Ramdev Wudali's Visual Thumbprint]https://www.vizify.com/es/5015811a501a700002000177

On Fri, Jan 3, 2014 at 2:38 PM, David Pilato david@pilato.fr wrote:

Is it a typo?

esNodes="elasticsearch.server:8300"

Should be 9300, right?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 21:35, Ramdev Wudali agastya71@gmail.com a écrit :

Hi David:
Thanks for the speedy response. Here is an update to my problem. I
was trying to create a different type within the same index. (Index:
experiment, type : Titles and I was trying to create Type : NewTitles ) I
am not sure if this has any bearing on the problem.

After posting the question on the group, I went ahead and created a
separate index (experiment2) and within this new index, I created the
Type: NewTitles.

When I ran my application, there was no problems during the Spring
elastic search client initialization.

This basically tells me there is a conflict in creation of a new Type
under an existing index. (I am not able to figure out why there is a
conflict).

And I am not mixing versions of ElasticSearch between client and node.
(both using 0.90.5)

hope this helps

Thanks

Ramdev

See my vizify bio!
[image: Ramdev Wudali's Visual Thumbprint]https://www.vizify.com/es/5015811a501a700002000177

On Fri, Jan 3, 2014 at 2:29 PM, David Pilato david@pilato.fr wrote:

Any chance you are mixing elasticsearch versions between node and
client?

--
David :wink:
Twitter : @dadoonet / @elasticsearchfr / @scrutmydocs

Le 3 janv. 2014 à 20:16, Ramdev Wudali agastya71@gmail.com a écrit :

Hi All:
I am trying to index a set of documents with the following mapping
:
{
"NewTitles": {
"properties": {
"DOC_ID": {
"type":"string"
},
"TITLE": {
"type": "multi_field",
"fields" : {
"TITLE" : {
"type" : "string"
},
"sortable" : {
"type" : "string",
"index" : "not_analyzed"
},
"autocomplete" : {
"type" : "string",
"index_analyzer" : "shingle_analyzer"
}
}
}
}
}
}

(which resides in the src/main/es/experiment folder in my project)

and there is a _settings.json file which defines the shingle_analyzer
like so :

{
"index" : {
"analysis": {
"filter": {
"shingle_filter": {
"type": "shingle",
"min_shingle_size": 2,
"max_shingle_size": 5
}
},
"analyzer": {
"shingle_analyzer": {
"type": "custom",
"tokenizer": "standard",
"filter": [
"lowercase",
"shingle_filter"
]
}
}
}
}
}

I am initializing the Elasticsearch client using the spring elastic
search like so :

 <util:map id="esProperties">
    <entry key="cluster.name" value="elasticsearch-experiment" />
</util:map>

 <elasticsearch:client id="esClient2"

mappings="experiment/NewTitles"
esNodes="elasticsearch.server:8300"
forceMapping="true"
properties="esProperties"/>

The elastic Search instance already has the index : experiment and Type
: Titles

When I run my app to index some new content, I get the an error during
Spring initialization, :

12:47:03.044 CST INFO [main ]
f.p.s.e.ElasticsearchTransportClientFactoryBean - Starting ElasticSearch
client
12:47:03.753 CST INFO [main ] org.elasticsearch.plugins -
[Ringleader] loaded [], sites []
Exception in thread "main"
org.springframework.beans.factory.BeanCreationException: Error creating
bean with name 'esClient2': Invocation of init method failed; nested
exception is org.elasticsearch.transport.TransportSerializationException:
Failed to deserialize exception response from stream

Upon checking the server as to the actual error :

[2014-01-03 12:47:08,554][DEBUG][action.admin.indices.mapping.put]
[Overkill] failed to put mappings on indices [[experiment]], type
[NewTitles]
org.elasticsearch.index.mapper.MapperParsingException: Analyzer
[shingle_analyzer] not found for field [autocomplete]
at
org.elasticsearch.index.mapper.core.TypeParsers.parseField(TypeParsers.java:107)
at
org.elasticsearch.index.mapper.core.StringFieldMapper$TypeParser.parse(StringFieldMapper.java:150)
at
org.elasticsearch.index.mapper.multifield.MultiFieldMapper$TypeParser.parse(MultiFieldMapper.java:133)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parseProperties(ObjectMapper.java:263)
at
org.elasticsearch.index.mapper.object.ObjectMapper$TypeParser.parse(ObjectMapper.java:219)
at
org.elasticsearch.index.mapper.DocumentMapperParser.parse(DocumentMapperParser.java:177)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:387)
at
org.elasticsearch.index.mapper.MapperService.parse(MapperService.java:383)
at
org.elasticsearch.cluster.metadata.MetaDataMappingService$4.execute(MetaDataMappingService.java:399)
at
org.elasticsearch.cluster.service.InternalClusterService$UpdateTask.run(InternalClusterService.java:298)
at
org.elasticsearch.common.util.concurrent.PrioritizedEsThreadPoolExecutor$TieBreakingPrioritizedRunnable.run(PrioritizedEsThreadPoolExecutor.java:135)
at
java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
at
java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
at java.lang.Thread.run(Thread.java:722)
"el

Does anyone have any idea what might be going on that would cause the
problem ? I have the _settings.json, and NewTitles.json both in the class
path and same folder. (as mentioned above).

Any help is appreciated.

Thanks

Ramdev

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.

To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/2b5610bc-5df1-41df-8e75-d3fecbca4a26%40googlegroups.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe
.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/8668EBCC-9952-4FB9-ACDB-85535F71C60C%40pilato.fr.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google
Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send
an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7h_Hs8fHhLPm2mO0U0mZBTfHJGPd0zt71vmrkgvQtFkFA%40mail.gmail.com
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/E725DE0D-17DD-4266-A0A8-FB6735D0CA36%40pilato.fr
.
For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7gvMFov5rXfXBB10oShbskCzCcnYY4dKQ6rMczg41mD-g%40mail.gmail.com.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/C5F69B12-DDC1-4515-B228-F35562D0F250%40pilato.fr.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups
"elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an
email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7itNarJhn_5mpiAUDGqUYPnFpERPpCMHUEfsOaq0QNcFQ%40mail.gmail.com
.

For more options, visit https://groups.google.com/groups/opt_out.

  • exlastic_example.tgz, 24 KB

--
You received this message because you are subscribed to a topic in the
Google Groups "elasticsearch" group.
To unsubscribe from this topic, visit
https://groups.google.com/d/topic/elasticsearch/sHU_4jzcTiI/unsubscribe.
To unsubscribe from this group and all its topics, send an email to
elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit
https://groups.google.com/d/msgid/elasticsearch/etPan.52ce6360.77ae35eb.1449b%40MacBook-Air-de-David.local
.

For more options, visit https://groups.google.com/groups/opt_out.

--
You received this message because you are subscribed to the Google Groups "elasticsearch" group.
To unsubscribe from this group and stop receiving emails from it, send an email to elasticsearch+unsubscribe@googlegroups.com.
To view this discussion on the web visit https://groups.google.com/d/msgid/elasticsearch/CAGbqZ7hrUeXmmZFO%3D8o5CjxruFu9V7eCLTKzdvvU771eTkjw3w%40mail.gmail.com.
For more options, visit https://groups.google.com/groups/opt_out.


(system) #10