SQL Access is missing in X-pack


(Walid rahmouni) #1

Hi,
After installing elasticsearch, I wanted to use the functionalities provided by SQL access, but unfortunately I could enable it. I'm using the basic license. When I want to run this instruction in kibana
POST /_xpack/sql?format=txt
{
"query": "SELECT * FROM w7_log "
}

I get this error

{
"error": {
"root_cause": [
{
"type": "invalid_index_name_exception",
"reason": "Invalid index name [xpack], must not start with '', '-', or '+'",
"index_uuid": "na",
"index": "_xpack"
}
],
"type": "invalid_index_name_exception",
"reason": "Invalid index name [xpack], must not start with '', '-', or '+'",
"index_uuid": "na",
"index": "_xpack"
},
"status": 400
}

I tried to add this setting "xpack.sql.enabled: true"into the elasticsearch.yml but I figured out that elasticsearch didn't start at all complaining that this setting doesn't exist.
This is also to mention that I installed the x-pack plugin separately and I still face the same issues.

I'm looking forward to your reply and your help.
Best regards,


(Christian Dahlqvist) #2

Are you running Elasticsearch 6.3?


(Walid rahmouni) #3

I was on an older version that's why it didn't work. Thanks for your support :slight_smile:


(Acepcs) #4

I think you'd better upgrade your es to 6.3


(Walid rahmouni) #5

Done and it works. Thank you.


(system) #6

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.