Start of Kibana fails

Hello! I have installed Kibana 8.8.1 on Windows Server 2012 from the downloaded .zip file. I want to access Kibana via a reverse-proxy site in IIS. Therefore, I have created a scheduled task that runs kibana.bat.
That task is run with a so-called service account. This service account is the owner of the directory where Kibana is installed, and also has full control in that directory. But starting Kibana this way, with this task, fails. In the Kibana log, the following error message appears:
"A system error occurred: uv_uptime returned EPERM (operation not permitted)".

However, when I run the task with my own account, it works, and even when I run kibana.bat myself from the command prompt .It feels like it has something to do with rights. But what rights are required, if so?

Any help is appreciated. Thanks in advance!


Hi @JohannesKjellberg,

That error suggests that the service account doesn't have sufficient permissions. Have you compared the permissions between yours and the service account, or tried running Kibana with admin?

Thanks for your quick answer. The service account is a domain account and is not a member of any other special group as far as I can see.
Yes, I have tried running as admin, ie. to add this service account to the local administrators group, and it works. But it is not the right way to go according to the policy at this company.
But I'm wondering if you look at the full error message with the stack-trace it looks like Kibana is trying to execute some java script. What could be the function that Kibana wants to use that it lacks rights to run?

A system error occurred: uv_uptime returned EPERM (operation not permitted)\n at OsMetricsCollector.collect (C:\Elasticsearch\kibana-8.8.1\node_modules\@kbn\core-metrics-collectors-server-internal \src\os.js:46:37)\n at OpsMetricsCollector.collect (C:\Elasticsearch\kibana-8.8.1\node_modules\@kbn\core-metrics-server-internal\ src\ops_metrics_collector.js:30:116)\n at MetricsService.refreshMetrics (C:\Elasticsearch\kibana-8.8.1\node_modules\@kbn\core-metrics-server-internal\src\ \metrics_service.js:61:49)\n at MetricsService.setup (C:\Elasticsearch\kibana-8.8.1\node_modules\@kbn\core-metrics-server-internal\src\metrics_service .js:43:16)\n at processTicksAndRejections (node:internal/process/task_queues:96:5)\n at Server.setup (C:\Elasticsearch\kibana-8.8.1\node_modules\@kbn \core-root-server-internal\src\server.js:253:26)\n at Root.setup (C:\Elasticsearch\kibana-8.8.1\node_modules\@kbn\ core-root-server-internal\src\root\index.js:55:14)\n at bootstrap (C:\Elasticsearch\kibana-8.8.1\node_modules\@kbn\core -root-server-internal\src\bootstrap.js:129:5)\n at Command. (C:\Elasticsearch\kibana-8.8.1\src\cli\serve\ \serve.js:276:5)"},"log":{"level":"FATAL","logger":"root"},"process":{"pid":4440},"trace": {"id":"89affc122ddd1e407df00f6cac0a6691"},"transaction":{"id":"8043df9b46a85587"}}


Thanks for sharing the full trace. I think you're correct that Kibana lacks the rights under that user to access the necessary Javascript. Can you check the permissions under the Kibana install folders? This old thread suggests that might help.

According to the old thread, the solution was a combination of changing permissions and not being able to write to a file. This permissions thing is interesting: is it possible to find out exactly what permissions a service account like this on Windows should have to work? As I wrote before: this service account has full control and is the owner of the entire directory, and all subdirectories, where Kibana is installed.


This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.