Kibana as a windows service : "Error 5: Access is Denied" on start


#1

Hi

I'm trying to get Kibana running as a windows service on an instance of Windows Server 2016.

I've followed the instructions to install Kibana detailed here: https://www.elastic.co/guide/en/kibana/current/windows.html

And then executed the following command in an elevated command window:
sc create "ElasticSearch Kibana " binPath= "C:/Elastic/kibana/bin" depend= "Elasticsearch"

This command was successful:

However, when I attempt to start the service, I get the following issue:

I have already ensured that the account that the service runs as has full permissions to the kibana.bat file; so there shouldn't be any file system permission issues. Additionally, if I run the bat file myself then the kibana server starts with no issue; so I dont think it's a config issue with Kibana.


(Jen Huang) #2

This sounds like a generic Windows configuration/permission issue, not a Kibana issue. Try the solution suggested here: https://stackoverflow.com/a/27608055


(Joe Fleming) #3

I also wonder if the error is coming from the Kibana service trying to write log files. Based on the search results I see, that error could result from seemingly any permissions issues.


#4

A good suggestion, but unfortunately one that I had already tried; the service doesn't execute when it runs as Local System account either.

I agree that it's unlikely to be a bug in Kibana or anything along those lines; I was just hoping I was missing something obvious..

Thanks for the quick response!


#5

Thanks for the suggestion; however I have also eliminated this as a possible cause. I configured kibana to log to a specific file, and when starting it manually it opens and runs fine (including outputting to the log file) -- however when I start the service I receive the same error.

I will have to try and figure out what this mysterious permissions issue could be.


#6

Fixed it;

Bascially, i'm an idiot -- binPath= "C:/Elastic/kibana/bin" should have been binPath= "C:/Elastic/kibana/bin/kibana.bat"

Figured I would post this here just for anyone googling around like I was.


(system) #7

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.