Access is denied

I have my Elasticsearch running on the default port and am able to login, so that is running fine.
I downloaded the from official elasticsearch site, extracted it to desktop, and tried running kibana.bat

This is what outputs to console...

Access is denied.</>

I have checked the user permissions under properties, and I have all admin permissions. I tried "Run as Administrator.", and that did nothing. The forums and guides etc. that I find on google have no solutions.

My first post btw, sorry if I used the </> wrong

Depending on your machine, sometimes running an exe from your desktop can be prohibited.

Can you rename the kibana-8.8.2 folder to kibana and move it to C:\Users\\%USERNAME%\Kibana ?

Then try the batch file again.

You can also try and move the Kibana folder to the root of C:\ if you have permission.

Is this the docs that you checked?

Moving it to those locations takes away all my permissions, I can't ls to list the items in the folder. I moved it back to Desktop, and now I can do ls again. Is it possible that third party software causes this? Like application monitoring/anti-virus etc.

Its always possible that AV gets in the way :sweat_smile:

If you have an AV - you may want to add your kibana folder to an exclusion list and give it a try.

It's surprising that you lose access when the folder is located in your \Users%USERNAME% folder since that is your user directory.

I ended talking to our Internal IT and Architect, they sorted it out. It was one of the AV software Agents causing this, the laptop I'm on is a Windows OS, so we have a lot of agents and stuff installed on here to monitor etc.

Great to hear!

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.