Stop autoformat dates in kibana filters


is there way to stop Kibana from autoformat date inputs in filters ?
my dates are in format DD.MM.YYYY but when I input it manully in filters its gonna convert automatically to 2018-01-01T00:00:00.000+01:00... As user, I want to state DD.MM.YYYY and not whole timecode in ISO8601 representation. But it gives me error for other vizualizations because its autoformatted to datetime format which is not in my data. I set the format in index pattern, also its in index management to DD.MM.YYYY but that didnt help. Thanks


I did more research and this also goes to simple operator "is".

When I use „Add filter“ on timefield productiondate with operator „is“ Kibana is accepting only YYYY-MM-DD format or MM.DD.YYYY format. However, my data is in DD.MM.YYYY format and I specifically wrote it in mapping.

But still I cant input 13.01.2021 (13 January) because filter thinks that 13 is month so its incorrect. If I switch it to 01.13.2021 I can click on save but DSL query behind doesnt work because my data is in DD.MM.YYYY, so its giving me errors for all visualizations on dashboard.
I tried other formats such as "dd.MM.yyyy||strict_date_optional_time||epoch_millis" but still its not working. Even when you use data sample index from Kibana, its not working properly.

Is there any solution or user must follow Kibana filter set up for YYYY-MM-DD?

Have you tried Kibana's advanced setting about Date format and Scaled date format?
You can access Management > Stack Management > Kibana > Advanced Settings > General. I'm not sure about the side effects of these settings and please follow the caution on top of the setting page.

Yes, didnt help...

I also tried and confirmed the same result.
Hmm, sorry, I have no idea..

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.