Swap still reported even though Page file is disabled


(John T) #1

I originally asked this question a while back:

I was never able to get around it. I just set up a new cluster with significantly more resources in the hopes of improving our perf. I still find that there is a ton of swapping going on.

I am on Windows (so I can't use Linux methods for preventing swapping). I have completely disabled paging and rebooted. After going this, I get:

PS C:\Windows\system32> Get-Counter -Counter "\Paging File(*)\% Usage"
Get-Counter : The specified instance is not present.
PS C:\Windows\system32> (gwmi Win32_ComputerSystem).AutomaticManagedPagefile
False
gwmi win32_pagefilesetting

Windows is showing that there is no swap, but I still see:

        "swap": {
           "total_in_bytes": 60129071104,
           "free_in_bytes": 26670817280,
           "used_in_bytes": 33458253824
        }

I can't seem to get around this. Here is what VMMap is showing

Has anyone been able to disable swapping on Windows?


(John T) #2

ping.
Is no one running Elasticsearch on Windows?


(John T) #3

a...parently not...


(David Pilato) #4

@Martijn_Laarman Do you think you can help here?


(system) #5

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.