Synthetic Monitoring in 7.12 version

I have installed Elasticsearch ver:7.12.1, Kibana ver:7.12.1, Heartbeat ver:7.17
I want to add Synthetic monitoring for a URL. Tried a sample inline code but it was not working.
Steps followed:

  1. Installed Elasticsearch
  2. Installed Kibana
    3 installed Heartbeat as service
    4 Made the following changes in heatbeat.yml file
    ('type:http' is been showing the url in uptime
    but 'type:browser' is not working)
    //Code
    </>

heartbeat.config.monitors:
path: "${path.config}/monitors.d/*.yml"
reload.enabled: false
reload.period: 5s
heartbeat.monitors:

enabled: false
id: my-monitor
name: "My Monitor"
schedule: "@every 10s"
type: http
urls: 
  - "http://localhost:9200"
  - "https://www.google.com"
  • enabled: false
    id: synthetic-inline-suites
    name: "Elastic website"
    schedule: "@every 1m"
    screenshots: "on"
    source:
    inline:
    script: "\n
    step("load homepage", async () => { \n\n
    \x20 await page.goto('https://www.elastic.co'); \n\n
    }); \n\n
    step("hover over products menu", async () => { \n\n
    \x20 await page.hover('css=[data-nav-item=products]'); \n\n
    }); "
    type: browser
    urls:
  • enabled: true
    id: todos
    name: Todos
    params:
    url: "Vue.js • TodoMVC"
    schedule: "@every 3m"
    screenshots: "on"
    source:
    zip_url:
    folder: synthetics-tests
    url: "https://github.com/elastic/synthetics-demo/archive/refs/heads/main.zip"
    tags: todos-app
    type: browser
    logging.level: debug
    output.elasticsearch:
    hosts:
  • add_observer_metadata: ~
    setup.kibana:
    host: "http://localhost:5601"
    setup.template.settings:
    index.codec: best_compression
    index.number_of_shards: 1
    </>

When using 'type: browser' , It's not been visible in uptime/downtime in kibana.
Please suggest what wrong in this process.

//Code
</>
heartbeat.config.monitors:
path: "${path.config}/monitors.d/*.yml"
reload.enabled: false
reload.period: 5s
heartbeat.monitors:

logging.level: debug
output.elasticsearch:
hosts:
"[http://localhost:9200]"

    • processors:
      add_observer_metadata: ~
      setup.kibana:
      host: "http://localhost:5601"
      setup.template.settings:
      index.codec: best_compression
      index.number_of_shards: 1

</>

Any words!! Any replies??