System module period

I'm using version 5.2.1 on Win10-x64, the metricbeat.yml is setup with a period of 10s see below, outputting to elasticsearch but the log shows the logging period always 30 seconds, I'm a new user what am I missing ?

metricbeat.exe -version
metricbeat version 5.2.1 (amd64), libbeat 5.2.1


#------------------------------- System Module -------------------------------
- module: system
    - cpu
    - filesystem
    - fsstat
    - memory
    - network
    - process
  enabled: true
  period: 10s
  processes: ['.*']


C:\Users\Win10-x64\Downloads\metricbeat-5.2.1-windows-x86_64>metricbeat.exe -e
2017/02/21 16:51:59.940291 beat.go:267: INFO Home path: [C:\Users\Win10-x64\Downloads\metricbeat-5.2.1-windows-x86_64] Config path: [C:\Users\Win10-x64\Downloads\metricbeat-5.2.1-windows-x86_64] Data path: [C:\Users\Win10-x64\Downloads\metricbeat-5.2.1-windows-x86_64\data] Logs path: [C:\Users\Win10-x64\Downloads\metricbeat-5.2.1-windows-x86_64\logs]
2017/02/21 16:51:59.942295 beat.go:177: INFO Setup Beat: metricbeat; Version: 5.2.1
2017/02/21 16:51:59.942295 output.go:167: INFO Loading template enabled. Reading template file: C:\Users\Win10-x64\Downloads\metricbeat-5.2.1-windows-x86_64\metricbeat.template.json
2017/02/21 16:51:59.944294 output.go:178: INFO Loading template enabled for Elasticsearch 2.x. Reading template file: C:\Users\Win10-x64\Downloads\metricbeat-5.2.1-windows-x86_64\metricbeat.template-es2x.json
2017/02/21 16:51:59.947303 client.go:120: INFO Elasticsearch url:
2017/02/21 16:51:59.947303 outputs.go:106: INFO Activated elasticsearch as output plugin.
2017/02/21 16:51:59.947303 publish.go:291: INFO Publisher name: DESKTOP-FKLSK0G
2017/02/21 16:51:59.949247 logp.go:219: INFO Metrics logging every 30s
2017/02/21 16:51:59.950317 async.go:63: INFO Flush Interval set to: 1s
2017/02/21 16:51:59.951335 async.go:64: INFO Max Bulk Size set to: 50


That message is about how ofter the logger writes metrics to the log. It has nothing to do with the collection period of the system module.

It would be better to look at the elapsed time between cpu events that have been written to Elasticsearch.

Your right I got confused, is there a way to change the logging period, I guess 30 seconds is decent enough if not.

See the documentation for logging. There is a configurable metrics period.

That's what got me confused in the first place, I see that the metrics period is configurable. I was referring to the logging period.

What do you find confusing about the logging documentation so that it can be improved?

Have you looked at the metricbeat.full.yml file that is provided in the download package? It contains an full example config with all of the options. In there you should see a commented out example line setting the logging.metrics.period to its default value of 30s.

logging.metrics.period: 30s

You can lower that value if you would like the logger to write out the values more often. To be clear, these are internal metrics about the Metricbeat process, not metrics that were collected by Metricbeat from the system or other processes.

I didn't know, thanks for enlightening me, I appreciate it.

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.