The default discovery settings are unsuitable for production use;

{ "type": "server", "timestamp": "2019-05-14T13:15:27,972+0000", "level": "DEBUG", "component": "o.e.a.ActionModule", "": "docker-cluster", "": "309a9b4e906e", "message": "Using REST wrapper from plugin" } {"type": "server", "timestamp": "2019-05-14T13:15:28,334+0000", "level": "INFO", "component": "o.e.d.DiscoveryModule", "": "docker-cluster", "": "309a9b4e906e", "message": "using discovery type [zen] and seed hosts providers [settings]" } {"type": "server", "timestamp": "2019-05-14T13:15:29,654+0000", "level": "INFO", "component": "o.e.n.Node", "": "docker-cluster", "": "309a9b4e906e", "message": "initialized" } {"type": "server", "timestamp": "2019-05-14T13:15:29,655+0000", "level": "INFO", "component": "o.e.n.Node", "": "docker-cluster", "": "309a9b4e906e", "message": "starting ..." } {"type": "server", "timestamp": "2019-05-14T13:15:30,020+0000", "level": "INFO", "component": "o.e.t.TransportService", "": "docker-cluster", "": "309a9b4e906e", "message": "publish_address {}, bound_addresses {}" } {"type": "server", "timestamp": "2019-05-14T13:15:30,057+0000", "level": "INFO", "component": "o.e.b.BootstrapChecks", "": "docker-cluster", "": "309a9b4e906e", "message": "bound or publishing to a non-loopback address, enforcing bootstrap checks" } ERROR: [1] bootstrap checks failed [1]: the default discovery settings are unsuitable for production use; at least one of [discovery.seed_hosts, discovery.seed_providers, cluster.initial_master_nodes] must be configured {"type": "server", "timestamp": "2019-05-14T13:15:30,083+0000", "level": "INFO", "component": "o.e.n.Node", "": "docker-cluster", "": "309a9b4e906e", "message": "stopping ..." } {"type": "server", "timestamp": "2019-05-14T13:15:30,178+0000", "level": "INFO", "component": "o.e.n.Node", "": "docker-cluster", "": "309a9b4e906e", "message": "stopped" } {"type": "server", "timestamp": "2019-05-14T13:15:30,179+0000", "level": "INFO", "component": "o.e.n.Node", "": "docker-cluster", "": "309a9b4e906e", "message": "closing ..." } {"type": "server", "timestamp": "2019-05-14T13:15:30,256+0000", "level": "INFO", "component": "o.e.n.Node", "": "docker-cluster", "": "309a9b4e906e", "message": "closed" }

I get this error when I try to run elastic search. I am creating a container from docker hub of elasticsearch and trying to run it.

Please format your code, logs or configuration files using </> icon as explained in this guide and not the citation button. It will make your post more readable.

Or use markdown style like:


This is the icon to use if you are not using markdown format:

There's a live preview panel for exactly this reasons.

Lots of people read these forums, and many of them will simply skip over a post that is difficult to read, because it's just too large an investment of their time to try and follow a wall of badly formatted text.
If your goal is to get an answer to your questions, it's in your interest to make it as easy to read and understand as possible.
Please update your post.

Could you share also how do you start the container?

The issue has been fixed.
I already had the stopped elaticsearch container in docker, which I started as docker start container_name

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.