This site can’t be reached xxx.xxx.xx refused to connect


(Krishnan Radhakrishnan) #1

http://public-ip:5601, i get below error

This site can’t be reached
xxx.xxx.xx refused to connect.

please help me to resolve


(Christian Dahlqvist) #2

Sounds like a firewall or networking problem, but you will need to provide more details around setup and configuration for anyone to be able to help beyond that.


(Krishnan Radhakrishnan) #3

etstat -natp | grep 5601(Not all processes could be identified, non-owned process info
will not be shown, you would have to be root to see it all.)
tcp 0 0 127.0.0.1:5601 0.0.0.0:* LISTEN

installting in ubuntu 16.04 virtual machine in azure and trying to access from my local machine

kibana.service - Kibana
Loaded: loaded (/etc/systemd/system/kibana.service; enabled; vendor preset: e
Active: active (running) since Sat 2018-06-02 11:48:09 UTC; 5h 0min ago

just show kibana is running but when called from internet with public ip:5601 , i get above error

when i tried to access from internet http://public-ip:5601, i get that error , can some one help please


(Christian Dahlqvist) #4

Kibana is listening to 127.0.1 which is only accessible from within the VM. Change it to bind to 0.0.0.0 (or the public IP) in the kibana.yml file and you should be able to access it from another machine.


(Krishnan Radhakrishnan) #5

still same . not able to load , below is my yml file

Kibana is served by a back end server. This controls which port to use.

server.port:5601

The host to bind the server to.

server.host:"0.0.0.0"

running kibana behind a proxy, and want to mount it at a path,

specify that path here. The basePath can't end in a slash.

server.basePath:"/kibana"

The maximum payload size in bytes on incoming server requests.

server.maxPayloadBytes: 1048576

The Elasticsearch instance to use for all your queries.

elasticsearch.url:"http://104.211.229.94:9200"

preserve_elasticsearch_host true will send the hostname specified in elasticsearch. If you set it to false,

then the host you use to connect to this Kibana instance will be sent.

elasticsearch.preserveHost:true

Kibana uses an index in Elasticsearch to store saved searches, visualizations

Type :quit to exit Vim


(Krishnan Radhakrishnan) #6

BINDING TO 0.0.0.0 NOT working when changed in yml file can some one help please


(Christian Dahlqvist) #7

In that case it sounds like you have firewall or networking issue. Check the firewall as well as any local VM settings.


(Krishnan Radhakrishnan) #8

no LUCK, VM machine is in azure , firewall is disabled with below command
sudo ufw disable
Firewall stopped and disabled on system startup

still i see this, Can some one help

tcp 0 0 127.0.0.1:5601 0.0.0.0:* LISTEN


(Christian Dahlqvist) #9

That still looks the same. Have you restarted Kibana?


(Krishnan Radhakrishnan) #10

sudo service kibana restart

did this but still same, something is not right


(Christian Dahlqvist) #11

It seems like it is not loading the config file you edited. Try shutting down the service and then make sure you have updated the right config file. Check the logs when starting up to see what it picks up.


(Krishnan Radhakrishnan) #12

the log is empty , when restarted this is what my yml file, can some one help


(system) #13

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.