This version of Kibana requires Elasticsearch v6.2.3 on all nodes


#1

Hello,

Still new to the Elastic stack, investigating, learning.. but occasionally I run into problems which take me hours without any sight of a solution, but in the end it's always some minor bug (yeah, I might have the tendency to overcomplicate stuff).

I was running Kibana locally with Elasticsearch and everything worked great, now I tried to connect Kibana to a remote instance of Elasticsearch and I keep getting this error no matter what I try:

This version of Kibana requires Elasticsearch v6.2.3 on all nodes. I found the following incompatible nodes in your cluster: v6.1.2 @ ..... (a list of clusters follows)

I guess I need to update Elasticsearch clusters, but it's already on 6.2.3, any ideas? There doesn't seem to be any working solution on google as I've tried all that made sense to me


(David Pilato) #2

Run

GET _cat/nodes?v

#3

I can not even access dev tools in Kibana, but I ran the command from terminal, it lists all of the nodes, but the same problem persists.


(Christian Dahlqvist) #4

Run this:

curl -X GET "localhost:9200/_cat/nodes?v&h=id,ip,port,v,m"

#5

It lists one node, but when trying to get back to dev tools in Kibana, it's still the same error.. tried turning it off and on again tho lol

Just to check, if I want to connect to a remote server with Kibana, I just edit the kibana.yml config file and under "elasticsearch.url: " add the remote connection instead of localhost?


(Christian Dahlqvist) #6

What version did it list?


#7

v 6.2.3


#8

Yeah I ran that command on localhost so it showed my version 6.2.3 node, after running it on the remote url, it listed all the nodes on version 6.1.2.
Downgraded Kibana to 6.1.2, everything works now, thanks for the help!


(system) #9

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.