Threadpool settings


(seant) #1

I've set my threadpool setting as follows:

threadpool:
index:
type: fixed
size: 1
wait_time: 60s
search:
type: fixed
size: 1
wait_time: 60s
bulk:
type: fixed
max: 1
wait_time: 1000s
refresh:
type: fixed
min: 1
wait_time: 1000s

...but I'm still seeing ~40 threads in htop.

I have 1 node w/ 1 shard and 0 replicas on es 0.19.7. Either my settings
are being ignored or I'm missing something.

My overall goal is to reduce the es memory footprint (I've set min/max mem,
reduced to 1 shard) ... is there anything else I should be doing to reduce
es memory consumption?

Thanks.


(system) #2