Timelion: Error: Max buckets exceeded: 10080 of 2000 allowed. Choose a larger interval or a shorter time span


#1

My Elastic Stack environment:

# cat /etc/redhat-release 
Red Hat Enterprise Linux Server release 7.4 (Maipo)
# rpm -q elasticsearch kibana metricbeat
elasticsearch-6.1.0-1.noarch
kibana-6.1.0-1.x86_64
metricbeat-6.1.0-1.x86_64
# 

I open [Metricbeat MySQL] Overview Dashboard and as soon as I change Time Range to be anything over Last 24 hours, I get red error line on top of my Kibana with following message:

Timelion: Error: Max buckets exceeded: 10080 of 2000 allowed. Choose a larger interval or a shorter time span

Please advise.


#2

I've found following in Kibana -> Management -> Advanced Settings -> timelion:max_buckets (default 200) and I increased it to 20000, Dashboard seems to be working now.


(system) #3

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.