Changes to Advanced Settings in Kibana not reflected


(Rohit Srinivasan) #1

Hi All,

Whenever I choose to view a dashboard with a time frame longer than 7 days, I get the following error:

"Metrics: Max buckets exceeded: 10080 is greater than 2000, try a larger time interval in the panel options."

This is also followed by warnings in the form of "Courier Fetch: X of 280 shards failed."

I attempted to resolve the 1st error message by modifying the value of "timelion:max_buckets" from 2000 to 43200. However, when I go back to the dashboard and attempt to view it, I get the same message and it seems that the value has not been changed from 2000.

Later, I tried to disable error & warning messages altogether by modifying the values of "notifications:lifetime:error" & "notifications:lifetime:warning" to "Infinity" but note that the messages still show up. I tried restarting Kibana service but was unsuccessful.

Is there something I'm missing to ensure that modifications to the advanced settings get honored? I'm running on version 6.2.2 with x-pack installed.

Any help would be appreciated. Thank you in advance!

Regards,
Rohit


(Jen Huang) #2

There are two max bucket settings: metrics:max_buckets and timelion:max_buckets. Dashboard doesn't support Timelion visualizations, so your visualization(s) will use the first metrics:max_buckets setting. Try increasing that value.


(Rohit Srinivasan) #3

That completely went unnoticed! Thank you! I've modified that value and it seems to work alright.

Thank you once again :slight_smile:


(system) #4

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.