Timelion is not reflecting the time series


(Logeswaran) #1

Hi Team,

I am new to Elastic Search. I have started exploring it and when I write my first timelion query it is not working. I am trying to generate the timeseries for the rejected percentage of the records.

.es(index=finalwmindex,timefield=process_start_time,q=status.keyword:COMPLETED,metric=sum:invalid_records_count).divide(.es(index=finalwmindex,timefield=process_start_time,q=status.keyword:COMPLETED,metric=sum:total_records_count)).multiply(100).


(Archana ) #2

Not sure if just a typo in this message, your in your actual query in timelion, but you have multipy instead of multiply.

What is the error you're getting?


(Logeswaran) #3

Sorry for the typo. I m not getting any errors. I have got the empty time series only.

But I have data points in the index.

I m trying to get the rejected percentage. If pipeline aggregation is possible in visualization then I can achieve it easily?


(Archana ) #4

Yes, you can definitely achieve this. I'm working on something locally. Will update!


(Logeswaran) #5

Sure will wait for the update.. Thanks


(Archana ) #6

Maybe your granularity is set too narrow or too broad. Do you have your setting at "auto"? You might try changing that.


(Logeswaran) #7

It worked. Thanks

@a5a
Are we still not supported with Pipeline Aggregation in Kibana Visualization?


(system) #8

This topic was automatically closed 28 days after the last reply. New replies are no longer allowed.